# CVE-2010-3198: Zope Denial of Service (DoS) vulnerability in ZServer

> Remote attackers can crash ZServer worker threads by triggering uncaught exceptions, causing a denial of service.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2010
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-qh4q-fwf8-qqrw, PYSEC-2010-32

## What is CVE-2010-3198?

CVE-2010-3198 is a medium-severity denial of service vulnerability in n/a, published on 8 Sep 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ZServer in Zope 2.10.x before 2.10.12 and 2.11.x before 2.11.7 allows remote attackers to cause a denial of service (crash of worker threads) via vectors that trigger uncaught exceptions.

## Which versions are affected by CVE-2010-3198?

5 open source packages ship an affected version, including zope and Zope. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zope` | PyPI | From 2.10.0 | 2.10.12, 2.11.7 |
| `zope` | PyPI | From 2.10.0 | 2.10.12 |
| `zope` | PyPI | From 2.11.0 | 2.11.7 |
| `Zope` | PyPI | From 2.10.0 | 2.10.12 |
| `Zope` | PyPI | From 2.11.0 | 2.11.7 |

Products: Zope Zope.

## How do I fix CVE-2010-3198?

Upgrade zope to a fixed version for your release line: 2.10.12 or 2.11.7.

## Is CVE-2010-3198 being exploited?

There is no known exploitation of CVE-2010-3198 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2000-0062](https://insights.sbomify.com/CVE-2000-0062/): Zope DTML implementation Improper Authentication (critical 10.0)
- [CVE-2021-32674](https://insights.sbomify.com/CVE-2021-32674/): Remote Code Execution via traversal in TAL expressions (high 8.8)
- [CVE-2000-1211](https://insights.sbomify.com/CVE-2000-1211/): Zope does not properly perform security registration for legacy names (high 7.5)
- [CVE-2002-0170](https://insights.sbomify.com/CVE-2002-0170/): Zope does not properly verify the access for objects with proxy roles (high 7.5)
- [CVE-2002-0688](https://insights.sbomify.com/CVE-2002-0688/): ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-3198 and fix it if it is affected.

What it is: CVE-2010-3198 is a medium-severity denial of service vulnerability in n/a, published on 8 Sep 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2010-3198 in the wild and no public exploit code.

Affected packages and fixed versions:
- zope (PyPI): affected from 2.10.0; fixed in 2.10.12, 2.11.7
- zope (PyPI): affected from 2.10.0; fixed in 2.10.12
- zope (PyPI): affected from 2.11.0; fixed in 2.11.7
- Zope (PyPI): affected from 2.10.0; fixed in 2.10.12
- Zope (PyPI): affected from 2.11.0; fixed in 2.11.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-3198/ (Markdown: https://insights.sbomify.com/CVE-2010-3198/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-3198
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-3198
- OSV: https://osv.dev/vulnerability/CVE-2010-3198

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-3198/
Summaries are generated and may contain mistakes; the official description above is the record.
