# CVE-2010-3300: Padding oracle attacks

> Attackers can exploit padding oracle vulnerabilities in OWASP ESAPI to decrypt sensitive data, requiring library upgrades.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2021
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-3gp6-hhfw-4gqx

## What is CVE-2010-3300?

CVE-2010-3300 is a medium-severity vulnerability in OWASP ESAPI, published on 22 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

It was found that all OWASP ESAPI for Java up to version 2.0 RC2 are vulnerable to padding oracle attacks.

Weakness: CWE-649 (Reliance on Obfuscation or Encryption of Security-Relevant Inputs without Integrity Checking)

## Which versions are affected by CVE-2010-3300?

2 open source packages ship an affected version, including org.owasp.esapi:esapi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.owasp.esapi:esapi` | Maven | All versions | 2.0GA |
| `org.owasp.esapi:esapi` | Maven | All versions | 2.0GA |

Products: Owasp Enterprise Security Api for Java.

## How do I fix CVE-2010-3300?

Upgrade org.owasp.esapi:esapi to 2.0GA or later.

## Is CVE-2010-3300 being exploited?

There is no known exploitation of CVE-2010-3300 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-3300 and fix it if it is affected.

What it is: CVE-2010-3300 is a medium-severity vulnerability in OWASP ESAPI, published on 22 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2010-3300 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.owasp.esapi:esapi (Maven): affected all versions; fixed in 2.0GA
- org.owasp.esapi:esapi (Maven): affected all versions; fixed in 2.0GA

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-3300/ (Markdown: https://insights.sbomify.com/CVE-2010-3300/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-3300
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-3300
- OSV: https://osv.dev/vulnerability/CVE-2010-3300

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-3300/
Summaries are generated and may contain mistakes; the official description above is the record.
