CVE-2010-3313 EGroupware Code Injection vulnerability
Remote attackers can execute arbitrary commands via shell metacharacters in spellchecker parameters, affecting EGroupware and EPL installations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2010-3313?
CVE-2010-3313 is a high-severity command injection vulnerability in n/a, published on 22 Sep 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
phpgwapi/js/fckeditor/editor/dialog/fck_spellerpages/spellerpages/serverscripts/spellchecker.php in EGroupware 1.4.001+.002; 1.6.001+.002 and possibly other versions before 1.6.003; and EPL 9.1 before 9.1.20100309 and 9.2 before 9.2.20100309; allows remote attackers to execute arbitrary commands via shell metacharacters in the (1) aspell_path or (2) spellchecker_lang parameters.
Weakness: CWE-94
Which versions are affected by CVE-2010-3313?
6 open source packages ship an affected version, including egroupware/egroupware. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
egroupware/egroupware Packagist | All versions | 1.6.003 |
egroupware/egroupware Packagist | All versions | 1.6.003 |
egroupware/egroupware Packagist | From 9.1 | 9.1.20100309 |
egroupware/egroupware Packagist | From 9.1 | 9.1.20100309 |
egroupware/egroupware Packagist | From 9.2 | 9.2.20100309 |
egroupware/egroupware Packagist | From 9.2 | 9.2.20100309 |
Products include Egroupware Egroupware.
How do I fix CVE-2010-3313?
Upgrade egroupware/egroupware to a fixed version for your release line: 1.6.003, 9.1.20100309 or 9.2.20100309.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2010-3313 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-3313 exists.
Public exploit code: 1 Exploit-DB entry.
Other vulnerabilities in n/a
- CVE-2008-2041 Code injection in n/a
- CVE-2007-3154 Unspecified vulnerability in Walter Zorn wz_tooltip.js (aka wz_tooltips) before 4.01, as used by eGroupWare before 1.2.107-2 and other packa
- CVE-2007-3155 Other in n/a
- CVE-2026-22243 EGroupware has SQL Injection in Nextmatch Filter Processing
- CVE-2014-2988 Code injection in n/a
Sources
Also known as GHSA-5gx6-f2qq-475f.