{"answers":{"affected":"6 open source packages ship an affected version, including egroupware/egroupware. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-3313 exists.","fix":"Upgrade egroupware/egroupware to a fixed version for your release line: 1.6.003, 9.1.20100309 or 9.2.20100309.","what":"CVE-2010-3313 is a high-severity command injection vulnerability in n/a, published on 22 Sep 2010. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2010-3313 and fix it if it is affected.\n\nWhat it is: CVE-2010-3313 is a high-severity command injection vulnerability in n/a, published on 22 Sep 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-3313 exists.\n\nAffected packages and fixed versions:\n- egroupware/egroupware (Packagist): affected all versions; fixed in 1.6.003\n- egroupware/egroupware (Packagist): affected all versions; fixed in 1.6.003\n- egroupware/egroupware (Packagist): affected from 9.1; fixed in 9.1.20100309\n- egroupware/egroupware (Packagist): affected from 9.1; fixed in 9.1.20100309\n- egroupware/egroupware (Packagist): affected from 9.2; fixed in 9.2.20100309\n- egroupware/egroupware (Packagist): affected from 9.2; fixed in 9.2.20100309\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-3313/ (Markdown: https://insights.sbomify.com/CVE-2010-3313/index.md)","id":"CVE-2010-3313","markdown":"https://insights.sbomify.com/CVE-2010-3313/index.md","name":"CVE-2010-3313","record":{"aliases":["GHSA-5gx6-f2qq-475f"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"EGroupware collaboration suite","requires_auth":"none","summary":"Remote attackers can execute arbitrary commands via shell metacharacters in spellchecker parameters, affecting EGroupware and EPL installations.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"egroupware","vendor":"egroupware"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"phpgwapi/js/fckeditor/editor/dialog/fck_spellerpages/spellerpages/serverscripts/spellchecker.php in EGroupware 1.4.001+.002; 1.6.001+.002 and possibly other versions before 1.6.003; and EPL 9.1 before 9.1.20100309 and 9.2 before 9.2.20100309; allows remote attackers to execute arbitrary commands via shell metacharacters in the (1) aspell_path or (2) spellchecker_lang parameters.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2010-03-16","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2010-03-16","kind":"exploitdb","ref":"11777","stars":null,"title":"eGroupWare 1.6.002 and eGroupWare premium line 9.1 - Multiple Vulnerabilities"}],"tier":"weaponised"},"has_fix":true,"headline":"EGroupware Code Injection vulnerability","id":"CVE-2010-3313","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"command_injection","year":"2010"},"n_packages":6,"n_references":4,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2010-3314"},"packages":[{"ecosystem":"Packagist","fixed":["1.6.003"],"introduced":["0"],"last_affected":[],"package":"egroupware/egroupware","purl":null,"source":"GHSA-5gx6-f2qq-475f"},{"ecosystem":"Packagist","fixed":["1.6.003"],"introduced":["0"],"last_affected":[],"package":"egroupware/egroupware","purl":"pkg:composer/egroupware/egroupware","source":"GHSA-5gx6-f2qq-475f"},{"ecosystem":"Packagist","fixed":["9.1.20100309"],"introduced":["9.1"],"last_affected":[],"package":"egroupware/egroupware","purl":null,"source":"GHSA-5gx6-f2qq-475f"},{"ecosystem":"Packagist","fixed":["9.1.20100309"],"introduced":["9.1"],"last_affected":[],"package":"egroupware/egroupware","purl":"pkg:composer/egroupware/egroupware","source":"GHSA-5gx6-f2qq-475f"},{"ecosystem":"Packagist","fixed":["9.2.20100309"],"introduced":["9.2"],"last_affected":[],"package":"egroupware/egroupware","purl":null,"source":"GHSA-5gx6-f2qq-475f"},{"ecosystem":"Packagist","fixed":["9.2.20100309"],"introduced":["9.2"],"last_affected":[],"package":"egroupware/egroupware","purl":"pkg:composer/egroupware/egroupware","source":"GHSA-5gx6-f2qq-475f"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2010-3312"},"products":["n/a"],"published":"2010-09-22","related":[{"cvss_score":10,"headline":"Code injection in n/a","id":"CVE-2008-2041","kev_date_added":null,"published":"2008-04-30"},{"cvss_score":10,"headline":"Unspecified vulnerability in Walter Zorn wz_tooltip.js (aka wz_tooltips) before 4.01, as used by eGroupWare before 1.2.107-2 and other packa","id":"CVE-2007-3154","kev_date_added":null,"published":"2007-06-11"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2007-3155","kev_date_added":null,"published":"2007-06-11"},{"cvss_score":8.7,"headline":"EGroupware has SQL Injection in Nextmatch Filter Processing","id":"CVE-2026-22243","kev_date_added":null,"published":"2026-01-28"},{"cvss_score":8.5,"headline":"Code injection in n/a","id":"CVE-2014-2988","kev_date_added":null,"published":"2014-10-27"},{"cvss_score":7.5,"headline":"Code injection in n/a","id":"CVE-2014-2027","kev_date_added":null,"published":"2015-03-31"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2011-4949","kev_date_added":null,"published":"2012-08-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary commands via shell metacharacters in spellchecker parameters, affecting EGroupware and EPL installations.","url":"https://insights.sbomify.com/CVE-2010-3313/"}