# CVE-2010-3313: EGroupware Code Injection vulnerability

> Remote attackers can execute arbitrary commands via shell metacharacters in spellchecker parameters, affecting EGroupware and EPL installations.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2010
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-5gx6-f2qq-475f

## What is CVE-2010-3313?

CVE-2010-3313 is a high-severity command injection vulnerability in n/a, published on 22 Sep 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

phpgwapi/js/fckeditor/editor/dialog/fck_spellerpages/spellerpages/serverscripts/spellchecker.php in EGroupware 1.4.001+.002; 1.6.001+.002 and possibly other versions before 1.6.003; and EPL 9.1 before 9.1.20100309 and 9.2 before 9.2.20100309; allows remote attackers to execute arbitrary commands via shell metacharacters in the (1) aspell_path or (2) spellchecker_lang parameters.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2010-3313?

6 open source packages ship an affected version, including egroupware/egroupware. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `egroupware/egroupware` | Packagist | All versions | 1.6.003 |
| `egroupware/egroupware` | Packagist | All versions | 1.6.003 |
| `egroupware/egroupware` | Packagist | From 9.1 | 9.1.20100309 |
| `egroupware/egroupware` | Packagist | From 9.1 | 9.1.20100309 |
| `egroupware/egroupware` | Packagist | From 9.2 | 9.2.20100309 |
| `egroupware/egroupware` | Packagist | From 9.2 | 9.2.20100309 |

Products: Egroupware Egroupware.

## How do I fix CVE-2010-3313?

Upgrade egroupware/egroupware to a fixed version for your release line: 1.6.003, 9.1.20100309 or 9.2.20100309.

## Is CVE-2010-3313 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-3313 exists.

Public exploit code:

- eGroupWare 1.6.002 and eGroupWare premium line 9.1 - Multiple Vulnerabilities (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2008-2041](https://insights.sbomify.com/CVE-2008-2041/): Code injection in n/a (critical 10.0)
- [CVE-2007-3154](https://insights.sbomify.com/CVE-2007-3154/): Unspecified vulnerability in Walter Zorn wz_tooltip.js (aka wz_tooltips) before 4.01, as used by eGroupWare before 1.2.107-2 and other packa (critical 10.0)
- [CVE-2007-3155](https://insights.sbomify.com/CVE-2007-3155/): Other in n/a (critical 10.0)
- [CVE-2026-22243](https://insights.sbomify.com/CVE-2026-22243/): EGroupware has SQL Injection in Nextmatch Filter Processing (high 8.7)
- [CVE-2014-2988](https://insights.sbomify.com/CVE-2014-2988/): Code injection in n/a (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-3313 and fix it if it is affected.

What it is: CVE-2010-3313 is a high-severity command injection vulnerability in n/a, published on 22 Sep 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-3313 exists.

Affected packages and fixed versions:
- egroupware/egroupware (Packagist): affected all versions; fixed in 1.6.003
- egroupware/egroupware (Packagist): affected all versions; fixed in 1.6.003
- egroupware/egroupware (Packagist): affected from 9.1; fixed in 9.1.20100309
- egroupware/egroupware (Packagist): affected from 9.1; fixed in 9.1.20100309
- egroupware/egroupware (Packagist): affected from 9.2; fixed in 9.2.20100309
- egroupware/egroupware (Packagist): affected from 9.2; fixed in 9.2.20100309

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-3313/ (Markdown: https://insights.sbomify.com/CVE-2010-3313/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-3313
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-3313
- OSV: https://osv.dev/vulnerability/CVE-2010-3313

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-3313/
Summaries are generated and may contain mistakes; the official description above is the record.
