# CVE-2010-3604: powermail extension for TYPO3 vulnerable to SQL Injection

> Remote attackers can execute arbitrary SQL commands in the TYPO3 powermail extension, potentially compromising database integrity and confidentiality.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2010
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-rp53-fw29-rxg3

## What is CVE-2010-3604?

CVE-2010-3604 is a high-severity SQL injection vulnerability in n/a, published on 24 Sep 2010. It can be exploited over the network, with no action from the victim.

### Official description

SQL injection vulnerability in the powermail extension 1.5.3 and earlier for TYPO3 allows remote attackers to execute arbitrary SQL commands via unspecified vectors.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2010-3604?

2 open source packages ship an affected version, including in2code/powermail. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `in2code/powermail` | Packagist | All versions | 1.5.4 |
| `in2code/powermail` | Packagist | All versions | 1.5.4 |

Products: Alex Kellner Powermail.

## How do I fix CVE-2010-3604?

Upgrade in2code/powermail to 1.5.4 or later.

## Is CVE-2010-3604 being exploited?

There is no known exploitation of CVE-2010-3604 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-3947](https://insights.sbomify.com/CVE-2014-3947/): TYPO3 powermail extension has unrestricted file upload vulnerability (high 7.5)
- [CVE-2014-6288](https://insights.sbomify.com/CVE-2014-6288/): TYPO3 powermail extension allows remote attackers to bypass CAPTCHA protection mechanism (high 7.5)
- [CVE-2010-0329](https://insights.sbomify.com/CVE-2010-0329/): TYPO3 powermail Extension Vulnerable to SQL Injection via Unspecified Vectors (high 7.5)
- [CVE-2010-3687](https://insights.sbomify.com/CVE-2010-3687/): Business logic in n/a (medium 5.0)
- [CVE-2014-3948](https://insights.sbomify.com/CVE-2014-3948/): Cross-site scripting in n/a (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-3604 and fix it if it is affected.

What it is: CVE-2010-3604 is a high-severity SQL injection vulnerability in n/a, published on 24 Sep 2010. It can be exploited over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2010-3604 in the wild and no public exploit code.

Affected packages and fixed versions:
- in2code/powermail (Packagist): affected all versions; fixed in 1.5.4
- in2code/powermail (Packagist): affected all versions; fixed in 1.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-3604/ (Markdown: https://insights.sbomify.com/CVE-2010-3604/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-3604
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-3604
- OSV: https://osv.dev/vulnerability/CVE-2010-3604

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-3604/
Summaries are generated and may contain mistakes; the official description above is the record.
