CVE-2010-3660 TYPO3 is vulnerable to Cross-Site Scripting (XSS) on the backend

Medium 5.4 Published Updated

Cross-site scripting vulnerability in TYPO3 backend allows attackers to inject malicious scripts, potentially compromising administrator sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2010-3660?

CVE-2010-3660 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 1 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 allows XSS on the backend.

Weakness: CWE-79

Which versions are affected by CVE-2010-3660?

8 open source packages ship an affected version, including typo3/cms-backend. It affects 1 product.

PackageAffectedFixed in
typo3/cms-backend PackagistAll versions4.1.14
typo3/cms-backend PackagistAll versions4.1.14
typo3/cms-backend PackagistFrom 4.2.04.2.13
typo3/cms-backend PackagistFrom 4.2.04.2.13
typo3/cms-backend PackagistFrom 4.3.04.3.4
typo3/cms-backend PackagistFrom 4.3.04.3.4
2 more packages
typo3/cms-backend PackagistFrom 4.4.04.4.1
typo3/cms-backend PackagistFrom 4.4.04.4.1

Products include Typo3 Typo3.

How do I fix CVE-2010-3660?

Upgrade typo3/cms-backend to a fixed version for your release line: 4.1.14, 4.2.13, 4.3.4 or 4.4.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2010-3660 being exploited?

There is no known exploitation of CVE-2010-3660 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as GHSA-cg45-qgcf-hf9x.

Is CVE-2010-3660 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free