CVE-2010-3663 TYPO3 Arbitrary Code Execution vulnerability on the backend

High 8.8 Published Updated

Remote attackers can execute arbitrary code via insecure default file upload restrictions in the TYPO3 backend.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2010-3663?

CVE-2010-3663 is a high-severity vulnerability in Typo3 Typo3, published on 4 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 contains an insecure default value of the variable fileDenyPattern which could allow remote attackers to execute arbitrary code on the backend.

Weakness: CWE-434

Which versions are affected by CVE-2010-3663?

8 open source packages ship an affected version, including typo3/cms-backend. It affects 1 product.

PackageAffectedFixed in
typo3/cms-backend PackagistAll versions4.1.14
typo3/cms-backend PackagistAll versions4.1.14
typo3/cms-backend PackagistFrom 4.24.2.13
typo3/cms-backend PackagistFrom 4.24.2.13
typo3/cms-backend PackagistFrom 4.34.3.4
typo3/cms-backend PackagistFrom 4.34.3.4
2 more packages
typo3/cms-backend PackagistFrom 4.44.4.1
typo3/cms-backend PackagistFrom 4.44.4.1

Products include Typo3 Typo3.

How do I fix CVE-2010-3663?

Upgrade typo3/cms-backend to a fixed version for your release line: 4.1.14, 4.2.13, 4.3.4 or 4.4.1.

Is CVE-2010-3663 being exploited?

There is no known exploitation of CVE-2010-3663 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as GHSA-wjpc-gjf7-9938.

Is CVE-2010-3663 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free