CVE-2010-3664 TYPO3 is vulnerable to Information Disclosure on the backend

Medium 6.5 Published Updated

An attacker can access sensitive backend information in TYPO3, potentially exposing internal data to unauthorized users.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2010-3664?

CVE-2010-3664 is a medium-severity vulnerability in Typo3 Typo3, published on 4 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 allows Information Disclosure on the backend.

Weakness: CWE-200

Which versions are affected by CVE-2010-3664?

8 open source packages ship an affected version, including typo3/cms-backend. It affects 1 product.

PackageAffectedFixed in
typo3/cms-backend PackagistAll versions4.1.14
typo3/cms-backend PackagistAll versions4.1.14
typo3/cms-backend PackagistFrom 4.2.04.2.13
typo3/cms-backend PackagistFrom 4.2.04.2.13
typo3/cms-backend PackagistFrom 4.3.04.3.4
typo3/cms-backend PackagistFrom 4.3.04.3.4
2 more packages
typo3/cms-backend PackagistFrom 4.4.04.4.1
typo3/cms-backend PackagistFrom 4.4.04.4.1

Products include Typo3 Typo3.

How do I fix CVE-2010-3664?

Upgrade typo3/cms-backend to a fixed version for your release line: 4.1.14, 4.2.13, 4.3.4 or 4.4.1.

Is CVE-2010-3664 being exploited?

There is no known exploitation of CVE-2010-3664 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as GHSA-8xp9-99h5-4vcg.

Is CVE-2010-3664 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free