CVE-2010-3672 TYPO3 vulnerable to Cross-Site Scripting in the textarea view helper

Medium 6.1 Published Updated

Cross-site scripting vulnerability in TYPO3 allows attackers to inject malicious scripts via the textarea view helper, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2010-3672?

CVE-2010-3672 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 5 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

TYPO3 before 4.3.4 and 4.4.x before 4.4.1 allows XSS in the textarea view helper in an extbase extension.

Weakness: CWE-79

Which versions are affected by CVE-2010-3672?

4 open source packages ship an affected version, including typo3/cms-fluid. It affects 1 product.

PackageAffectedFixed in
typo3/cms-fluid PackagistAll versions4.3.4
typo3/cms-fluid PackagistAll versions4.3.4
typo3/cms-fluid PackagistFrom 4.4.04.4.1
typo3/cms-fluid PackagistFrom 4.4.04.4.1

Products include Typo3 Typo3.

How do I fix CVE-2010-3672?

Upgrade typo3/cms-fluid to a fixed version for your release line: 4.3.4 or 4.4.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2010-3672 being exploited?

There is no known exploitation of CVE-2010-3672 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as GHSA-p78x-93mq-qwqh.

Is CVE-2010-3672 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free