# CVE-2010-3672: TYPO3 vulnerable to Cross-Site Scripting in the textarea view helper

> Cross-site scripting vulnerability in TYPO3 allows attackers to inject malicious scripts via the textarea view helper, potentially compromising user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Nov 2019
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-p78x-93mq-qwqh

## What is CVE-2010-3672?

CVE-2010-3672 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 5 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

TYPO3 before 4.3.4 and 4.4.x before 4.4.1 allows XSS in the textarea view helper in an extbase extension.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2010-3672?

4 open source packages ship an affected version, including typo3/cms-fluid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms-fluid` | Packagist | All versions | 4.3.4 |
| `typo3/cms-fluid` | Packagist | All versions | 4.3.4 |
| `typo3/cms-fluid` | Packagist | From 4.4.0 | 4.4.1 |
| `typo3/cms-fluid` | Packagist | From 4.4.0 | 4.4.1 |

Products: Typo3 Typo3.

## How do I fix CVE-2010-3672?

Upgrade typo3/cms-fluid to a fixed version for your release line: 4.3.4 or 4.4.1.

## Is CVE-2010-3672 being exploited?

There is no known exploitation of CVE-2010-3672 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-3672 and fix it if it is affected.

What it is: CVE-2010-3672 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 5 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2010-3672 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms-fluid (Packagist): affected all versions; fixed in 4.3.4
- typo3/cms-fluid (Packagist): affected all versions; fixed in 4.3.4
- typo3/cms-fluid (Packagist): affected from 4.4.0; fixed in 4.4.1
- typo3/cms-fluid (Packagist): affected from 4.4.0; fixed in 4.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-3672/ (Markdown: https://insights.sbomify.com/CVE-2010-3672/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-3672
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-3672
- OSV: https://osv.dev/vulnerability/CVE-2010-3672

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-3672/
Summaries are generated and may contain mistakes; the official description above is the record.
