# CVE-2010-3700: Authentication Bypass Using an Alternate Path or Channel in SpringSource Spring Security and Acegi Security

> Remote attackers can bypass security constraints in Spring Security via path parameters, potentially accessing restricted resources without authorization.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Oct 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-3295-h9qx-r82x

## What is CVE-2010-3700?

CVE-2010-3700 is a medium-severity vulnerability in Ibm Websphere Application Server, published on 29 Oct 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

VMware SpringSource Spring Security 2.x before 2.0.6 and 3.x before 3.0.4, and Acegi Security 1.0.0 through 1.0.7, as used in IBM WebSphere Application Server (WAS) 6.1 and 7.0, allows remote attackers to bypass security constraints via a path parameter.

Weakness: CWE-264

## Which versions are affected by CVE-2010-3700?

6 open source packages ship an affected version, including org.springframework.security:spring-security-core and org.acegisecurity:acegi-security. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-core` | Maven | From 2.0.0 | 2.0.6 |
| `org.springframework.security:spring-security-core` | Maven | From 2.0.0 | 2.0.6 |
| `org.springframework.security:spring-security-core` | Maven | From 3.0.0 | 3.0.4 |
| `org.springframework.security:spring-security-core` | Maven | From 3.0.0 | 3.0.4 |
| `org.acegisecurity:acegi-security` | Maven | From 1.0.0 to 1.0.7 | None |
| `org.acegisecurity:acegi-security` | Maven | From 1.0.0 to 1.0.7 | None |

Products: Acegisecurity Acegi-Security, Ibm Websphere Application Server, Vmware Springsource Spring Security.

## How do I fix CVE-2010-3700?

Upgrade org.springframework.security:spring-security-core to a fixed version for your release line: 2.0.6 or 3.0.4.

## Is CVE-2010-3700 being exploited?

There is no known exploitation of CVE-2010-3700 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-3700 and fix it if it is affected.

What it is: CVE-2010-3700 is a medium-severity vulnerability in Ibm Websphere Application Server, published on 29 Oct 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2010-3700 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-core (Maven): affected from 2.0.0; fixed in 2.0.6
- org.springframework.security:spring-security-core (Maven): affected from 2.0.0; fixed in 2.0.6
- org.springframework.security:spring-security-core (Maven): affected from 3.0.0; fixed in 3.0.4
- org.springframework.security:spring-security-core (Maven): affected from 3.0.0; fixed in 3.0.4
- org.acegisecurity:acegi-security (Maven): affected from 1.0.0 up to 1.0.7; no fix listed
- org.acegisecurity:acegi-security (Maven): affected from 1.0.0 up to 1.0.7; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-3700/ (Markdown: https://insights.sbomify.com/CVE-2010-3700/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-3700
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-3700
- OSV: https://osv.dev/vulnerability/CVE-2010-3700

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-3700/
Summaries are generated and may contain mistakes; the official description above is the record.
