# CVE-2010-3708: Drools Improper Input Validation vulnerability allows remote attackers to execute arbitrary code in JBoss EAP

> Remote attackers can execute arbitrary code on JBoss EAP and SOA Platform by exploiting unsafe deserialization of embedded class files.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Dec 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-qvq6-cw53-rmwg

## What is CVE-2010-3708?

CVE-2010-3708 is a high-severity unsafe deserialization vulnerability in Redhat Jboss Enterprise Application Platform, published on 30 Dec 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The serialization implementation in JBoss Drools in Red Hat JBoss Enterprise Application Platform (aka JBoss EAP or JBEAP) 4.3 before 4.3.0.CP09 and JBoss Enterprise SOA Platform 4.2 and 4.3 supports the embedding of class files, which allows remote attackers to execute arbitrary code via a crafted static initializer.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2010-3708?

2 open source packages ship an affected version, including org.drools:drools-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.drools:drools-core` | Maven | All versions | 4.0.7 |
| `org.drools:drools-core` | Maven | All versions | 4.0.7 |

Products: Redhat Jboss Enterprise Application Platform, Redhat Jboss Enterprise Soa Platform.

## How do I fix CVE-2010-3708?

Upgrade org.drools:drools-core to 4.0.7 or later.

## Is CVE-2010-3708 being exploited?

There is no known exploitation of CVE-2010-3708 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Jboss Enterprise Application Platform

- [CVE-2017-12149](https://insights.sbomify.com/CVE-2017-12149/): Red Hat JBoss Application Server Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2010-1428](https://insights.sbomify.com/CVE-2010-1428/): Red Hat JBoss Information Disclosure (medium 5.9, exploited in the wild)
- [CVE-2010-0738](https://insights.sbomify.com/CVE-2010-0738/): Red Hat JBoss Authentication Bypass (low 3.7, exploited in the wild)
- [CVE-2016-3690](https://insights.sbomify.com/CVE-2016-3690/): Deserialization in n/a (critical 9.8)
- [CVE-2017-7504](https://insights.sbomify.com/CVE-2017-7504/): Deserialization in JBoss (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-3708 and fix it if it is affected.

What it is: CVE-2010-3708 is a high-severity unsafe deserialization vulnerability in Redhat Jboss Enterprise Application Platform, published on 30 Dec 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2010-3708 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.drools:drools-core (Maven): affected all versions; fixed in 4.0.7
- org.drools:drools-core (Maven): affected all versions; fixed in 4.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-3708/ (Markdown: https://insights.sbomify.com/CVE-2010-3708/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-3708
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-3708
- OSV: https://osv.dev/vulnerability/CVE-2010-3708

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-3708/
Summaries are generated and may contain mistakes; the official description above is the record.
