# CVE-2010-3714: TYPO3 Remote File Disclosure vulnerability in the jumpUrl mechanism

> Remote attackers can read arbitrary files in TYPO3 due to improper hash comparison in the jumpUrl implementation.

- **Severity:** High 7.1 (`AV:N/AC:M/Au:N/C:C/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-w736-qv86-vq94

## What is CVE-2010-3714?

CVE-2010-3714 is a high-severity path traversal vulnerability in Typo3 Typo3, published on 25 Oct 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The jumpUrl (aka access tracking) implementation in tslib/class.tslib_fe.php in TYPO3 4.2.x before 4.2.15, 4.3.x before 4.3.7, and 4.4.x before 4.4.4 does not properly compare certain hash values during access-control decisions, which allows remote attackers to read arbitrary files via unspecified vectors.

Weakness: CWE-264

## Which versions are affected by CVE-2010-3714?

6 open source packages ship an affected version, including typo3/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms` | Packagist | From 4.2.0 | 4.2.15 |
| `typo3/cms` | Packagist | From 4.2.0 | 4.2.15 |
| `typo3/cms` | Packagist | From 4.3.0 | 4.3.7 |
| `typo3/cms` | Packagist | From 4.3.0 | 4.3.7 |
| `typo3/cms` | Packagist | From 4.4.0 | 4.4.4 |
| `typo3/cms` | Packagist | From 4.4.0 | 4.4.4 |

Products: Typo3 Typo3.

## How do I fix CVE-2010-3714?

Upgrade typo3/cms to a fixed version for your release line: 4.2.15, 4.3.7 or 4.4.4.

## Is CVE-2010-3714 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-3714 exists.

Public exploit code:

- TYPO3 - Arbitrary File Retrieval (exploitdb)
- TYPO3 sa-2010-020 Remote File Disclosure (metasploit)

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-3714 and fix it if it is affected.

What it is: CVE-2010-3714 is a high-severity path traversal vulnerability in Typo3 Typo3, published on 25 Oct 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-3714 exists.

Affected packages and fixed versions:
- typo3/cms (Packagist): affected from 4.2.0; fixed in 4.2.15
- typo3/cms (Packagist): affected from 4.2.0; fixed in 4.2.15
- typo3/cms (Packagist): affected from 4.3.0; fixed in 4.3.7
- typo3/cms (Packagist): affected from 4.3.0; fixed in 4.3.7
- typo3/cms (Packagist): affected from 4.4.0; fixed in 4.4.4
- typo3/cms (Packagist): affected from 4.4.0; fixed in 4.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-3714/ (Markdown: https://insights.sbomify.com/CVE-2010-3714/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-3714
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-3714
- OSV: https://osv.dev/vulnerability/CVE-2010-3714

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-3714/
Summaries are generated and may contain mistakes; the official description above is the record.
