# CVE-2010-3718: Improper Limitation of a Pathname to a Restricted Directory in Apache Tomcat

> Local web applications can read or write files outside the working directory via path traversal when Tomcat runs with a SecurityManager.

- **Severity:** Low 1.2 (`AV:L/AC:H/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Feb 2011
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-fj6c-prgj-gr3r

## What is CVE-2010-3718?

CVE-2010-3718 is a low-severity path traversal vulnerability in Apache Tomcat, published on 10 Feb 2011. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Apache Tomcat 7.0.0 through 7.0.3, 6.0.x, and 5.5.x, when running within a SecurityManager, does not make the ServletContext attribute read-only, which allows local web applications to read or write files outside of the intended working directory, as demonstrated using a directory traversal attack.

## Which versions are affected by CVE-2010-3718?

6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 | 5.5.30 |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 | 5.5.30 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.30 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.30 |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.0 | 7.0.4 |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.0 | 7.0.4 |

Products: Apache Tomcat.

## How do I fix CVE-2010-3718?

Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 5.5.30, 6.0.30 or 7.0.4.

## Is CVE-2010-3718 being exploited?

There is no known exploitation of CVE-2010-3718 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-3718 and fix it if it is affected.

What it is: CVE-2010-3718 is a low-severity path traversal vulnerability in Apache Tomcat, published on 10 Feb 2011. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2010-3718 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0; fixed in 5.5.30
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0; fixed in 5.5.30
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.30
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.30
- org.apache.tomcat:tomcat (Maven): affected from 7.0.0; fixed in 7.0.4
- org.apache.tomcat:tomcat (Maven): affected from 7.0.0; fixed in 7.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-3718/ (Markdown: https://insights.sbomify.com/CVE-2010-3718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-3718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-3718
- OSV: https://osv.dev/vulnerability/CVE-2010-3718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-3718/
Summaries are generated and may contain mistakes; the official description above is the record.
