CVE-2010-3978 Spree allows remote attackers to obtain sensitive information

Medium 5.0 Published Updated

Remote attackers can obtain sensitive information from admin JSON endpoints via JSON hijacking, requiring authenticated admin access and user interaction.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2010-3978?

CVE-2010-3978 is a medium-severity vulnerability in n/a, published on 17 Nov 2010. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Spree 0.11.x before 0.11.2 and 0.30.x before 0.30.0 exchanges data using JavaScript Object Notation (JSON) without a mechanism for validating requests, which allows remote attackers to obtain sensitive information via vectors involving (1) admin/products.json, (2) admin/users.json, or (3) admin/overview/get_report_data, related to a "JSON hijacking" issue.

Weakness: CWE-200

Which versions are affected by CVE-2010-3978?

4 open source packages ship an affected version, including spree. It affects 1 product.

PackageAffectedFixed in
spree RubyGemsFrom 0.11.00.11.2
spree RubyGemsFrom 0.11.00.11.2
spree RubyGemsFrom 0.30.0.beta10.30.0
spree RubyGemsFrom 0.30.0.beta10.30.0

Products include Spreecommerce Spree.

How do I fix CVE-2010-3978?

Upgrade spree to a fixed version for your release line: 0.11.2 or 0.30.0.

Is CVE-2010-3978 being exploited?

There is no known exploitation of CVE-2010-3978 in the wild and no public exploit code.

Sources

Also known as GHSA-hwrx-wc75-mgh7.

Is CVE-2010-3978 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free