# CVE-2010-3978: Spree allows remote attackers to obtain sensitive information

> Remote attackers can obtain sensitive information from admin JSON endpoints via JSON hijacking, requiring authenticated admin access and user interaction.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Nov 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-hwrx-wc75-mgh7

## What is CVE-2010-3978?

CVE-2010-3978 is a medium-severity vulnerability in n/a, published on 17 Nov 2010. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Spree 0.11.x before 0.11.2 and 0.30.x before 0.30.0 exchanges data using JavaScript Object Notation (JSON) without a mechanism for validating requests, which allows remote attackers to obtain sensitive information via vectors involving (1) admin/products.json, (2) admin/users.json, or (3) admin/overview/get_report_data, related to a "JSON hijacking" issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2010-3978?

4 open source packages ship an affected version, including spree. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `spree` | RubyGems | From 0.11.0 | 0.11.2 |
| `spree` | RubyGems | From 0.11.0 | 0.11.2 |
| `spree` | RubyGems | From 0.30.0.beta1 | 0.30.0 |
| `spree` | RubyGems | From 0.30.0.beta1 | 0.30.0 |

Products: Spreecommerce Spree.

## How do I fix CVE-2010-3978?

Upgrade spree to a fixed version for your release line: 0.11.2 or 0.30.0.

## Is CVE-2010-3978 being exploited?

There is no known exploitation of CVE-2010-3978 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2011-10019](https://insights.sbomify.com/CVE-2011-10019/): Spreecommerce < 0.60.2 Search Parameter RCE (critical 10.0)
- [CVE-2011-10026](https://insights.sbomify.com/CVE-2011-10026/): Spreecommerce < 0.50.x API RCE (critical 9.3)
- [CVE-2026-25757](https://insights.sbomify.com/CVE-2026-25757/): Unauthenticated Spree Commerce users can view completed guest orders by Order ID (high 7.7)
- [CVE-2026-25758](https://insights.sbomify.com/CVE-2026-25758/): Spree allows unauthenticated users can access all guest addresses (high 7.7)
- [CVE-2020-26223](https://insights.sbomify.com/CVE-2020-26223/): Authorization bypass in Spree (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-3978 and fix it if it is affected.

What it is: CVE-2010-3978 is a medium-severity vulnerability in n/a, published on 17 Nov 2010. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2010-3978 in the wild and no public exploit code.

Affected packages and fixed versions:
- spree (RubyGems): affected from 0.11.0; fixed in 0.11.2
- spree (RubyGems): affected from 0.11.0; fixed in 0.11.2
- spree (RubyGems): affected from 0.30.0.beta1; fixed in 0.30.0
- spree (RubyGems): affected from 0.30.0.beta1; fixed in 0.30.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-3978/ (Markdown: https://insights.sbomify.com/CVE-2010-3978/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-3978
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-3978
- OSV: https://osv.dev/vulnerability/CVE-2010-3978

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-3978/
Summaries are generated and may contain mistakes; the official description above is the record.
