# CVE-2010-4172: Improper Neutralization of Input During Web Page Generation in Apache Tomcat

> Remote attackers can inject arbitrary web script or HTML into the Apache Tomcat Manager application, potentially leading to session hijacking or code execution.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Nov 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-c78g-qwpw-2jgv

## What is CVE-2010-4172?

CVE-2010-4172 is a medium-severity cross-site scripting vulnerability in Apache Tomcat, published on 26 Nov 2010. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in the Manager application in Apache Tomcat 6.0.12 through 6.0.29 and 7.0.0 through 7.0.4 allow remote attackers to inject arbitrary web script or HTML via the (1) orderBy or (2) sort parameter to sessionsList.jsp, or unspecified input to (3) sessionDetail.jsp or (4) java/org/apache/catalina/manager/JspHelper.java, related to use of untrusted web applications.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2010-4172?

4 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.12 to 6.0.29 | None |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.12 to 6.0.29 | None |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.0 | 7.0.5 |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.0 | 7.0.5 |

Products: Apache Tomcat.

## How do I fix CVE-2010-4172?

Upgrade org.apache.tomcat:tomcat to 7.0.5 or later.

## Is CVE-2010-4172 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-4172 exists.

Public exploit code:

- Apache Tomcat 7.0.4 - 'sort' / 'orderBy' Cross-Site Scripting (exploitdb)

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-4172 and fix it if it is affected.

What it is: CVE-2010-4172 is a medium-severity cross-site scripting vulnerability in Apache Tomcat, published on 26 Nov 2010. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-4172 exists.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected from 6.0.12 up to 6.0.29; no fix listed
- org.apache.tomcat:tomcat (Maven): affected from 6.0.12 up to 6.0.29; no fix listed
- org.apache.tomcat:tomcat (Maven): affected from 7.0.0; fixed in 7.0.5
- org.apache.tomcat:tomcat (Maven): affected from 7.0.0; fixed in 7.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-4172/ (Markdown: https://insights.sbomify.com/CVE-2010-4172/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-4172
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-4172
- OSV: https://osv.dev/vulnerability/CVE-2010-4172

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-4172/
Summaries are generated and may contain mistakes; the official description above is the record.
