{"answers":{"affected":"2 open source packages ship an affected version, including cakephp/cakephp. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-4335 exists.","fix":"Upgrade cakephp/cakephp to 1.3.6 or later.","what":"CVE-2010-4335 is a high-severity unsafe deserialization vulnerability in n/a, published on 14 Jan 2011. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2010-4335 and fix it if it is affected.\n\nWhat it is: CVE-2010-4335 is a high-severity unsafe deserialization vulnerability in n/a, published on 14 Jan 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-4335 exists.\n\nAffected packages and fixed versions:\n- cakephp/cakephp (Packagist): affected from 1.2.8; fixed in 1.3.6\n- cakephp/cakephp (Packagist): affected from 1.2.8; fixed in 1.3.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-4335/ (Markdown: https://insights.sbomify.com/CVE-2010-4335/index.md)","id":"CVE-2010-4335","markdown":"https://insights.sbomify.com/CVE-2010-4335/index.md","name":"CVE-2010-4335","record":{"aliases":["DEBIAN-CVE-2010-4335","GHSA-g2vx-8v47-4vhh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"CakePHP framework","requires_auth":"none","summary":"Remote attackers can execute arbitrary code by sending crafted data that triggers unsafe deserialization in the CakePHP security component.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"cakephp","vendor":"cakefoundation"},{"product":"cakephp","vendor":"cakephp"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The _validatePost function in libs/controller/components/security.php in CakePHP 1.3.x through 1.3.5 and 1.2.8 allows remote attackers to modify the internal Cake cache and execute arbitrary code via a crafted data[_Token][fields] value that is processed by the unserialize function, as demonstrated by modifying the file_map cache to execute arbitrary local files.","ecosystems":["Packagist"],"exploits":{"exploitdb":2,"first_seen":"2010-11-15","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":0,"refs":[{"date":"2010-11-15","kind":"metasploit","ref":"exploit/unix/webapp/cakephp_cache_corruption","stars":null,"title":"CakePHP Cache Corruption Code Execution"},{"date":"2011-01-14","kind":"exploitdb","ref":"16902","stars":null,"title":"CakePHP 1.3.5/1.2.8 - Cache Corruption (Metasploit)"},{"date":"2011-01-18","kind":"exploitdb","ref":"16011","stars":null,"title":"CakePHP 1.3.5/1.2.8 - 'Unserialize()' File Inclusion"}],"tier":"weaponised"},"has_fix":true,"headline":"CakePHP allows remote attackers to modify internal Cake cache and execute arbitrary code","id":"CVE-2010-4335","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2010"},"n_packages":2,"n_references":7,"next":{"headline":"Denial of service in n/a","id":"CVE-2010-4336"},"packages":[{"ecosystem":"Packagist","fixed":["1.3.6"],"introduced":["1.2.8"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-g2vx-8v47-4vhh"},{"ecosystem":"Packagist","fixed":["1.3.6"],"introduced":["1.2.8"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-g2vx-8v47-4vhh"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2010-4334"},"products":["n/a"],"published":"2011-01-14","related":[{"cvss_score":7.5,"headline":"CakePHPallows remote attackers to read arbitrary files via XML data containing external entity references","id":"CVE-2012-4399","kev_date_added":null,"published":"2012-10-09"},{"cvss_score":4.3,"headline":"Cross-Site Request Forgery in CakePHP","id":"CVE-2020-15400","kev_date_added":null,"published":"2020-06-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code by sending crafted data that triggers unsafe deserialization in the CakePHP security component.","url":"https://insights.sbomify.com/CVE-2010-4335/"}