CVE-2010-4340 Apache Libcloud does not verify SSL certificates for HTTPS connections
Attackers can bypass SSL certificate verification in libcloud via man-in-the-middle attacks, allowing them to spoof certificates and bypass access restrictions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2010-4340?
CVE-2010-4340 is a medium-severity vulnerability in n/a, published on 11 Sep 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
libcloud before 0.4.1 does not verify SSL certificates for HTTPS connections, which allows remote attackers to spoof certificates and bypass intended access restrictions via a man-in-the-middle (MITM) attack.
Weakness: CWE-264
Which versions are affected by CVE-2010-4340?
3 open source packages ship an affected version, including apache-libcloud. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache-libcloud PyPI | All versions | 0.4.0 |
apache-libcloud PyPI | All versions | 0.4.0 |
apache-libcloud PyPI | All versions | 0.4.2 |
Products include Apache Libcloud.
How do I fix CVE-2010-4340?
Upgrade apache-libcloud to a fixed version for your release line: 0.4.0 or 0.4.2.
Is CVE-2010-4340 being exploited?
There is no known exploitation of CVE-2010-4340 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as DEBIAN-CVE-2010-4340, GHSA-w3j6-8j34-q43x, PYSEC-2011-24.