# CVE-2010-4340: Apache Libcloud does not verify SSL certificates for HTTPS connections

> Attackers can bypass SSL certificate verification in libcloud via man-in-the-middle attacks, allowing them to spoof certificates and bypass access restrictions.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Sep 2011
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2010-4340, GHSA-w3j6-8j34-q43x, PYSEC-2011-24

## What is CVE-2010-4340?

CVE-2010-4340 is a medium-severity vulnerability in n/a, published on 11 Sep 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libcloud before 0.4.1 does not verify SSL certificates for HTTPS connections, which allows remote attackers to spoof certificates and bypass intended access restrictions via a man-in-the-middle (MITM) attack.

Weakness: CWE-264

## Which versions are affected by CVE-2010-4340?

3 open source packages ship an affected version, including apache-libcloud. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-libcloud` | PyPI | All versions | 0.4.0 |
| `apache-libcloud` | PyPI | All versions | 0.4.0 |
| `apache-libcloud` | PyPI | All versions | 0.4.2 |

Products: Apache Libcloud.

## How do I fix CVE-2010-4340?

Upgrade apache-libcloud to a fixed version for your release line: 0.4.0 or 0.4.2.

## Is CVE-2010-4340 being exploited?

There is no known exploitation of CVE-2010-4340 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2012-3446](https://insights.sbomify.com/CVE-2012-3446/): Apache Libcloud vulnerable to certificate impersonation (medium 5.9)
- [CVE-2013-6480](https://insights.sbomify.com/CVE-2013-6480/): Libcloud does not properly scrub data when destroying a DigitalOcean node (low 2.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-4340 and fix it if it is affected.

What it is: CVE-2010-4340 is a medium-severity vulnerability in n/a, published on 11 Sep 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2010-4340 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-libcloud (PyPI): affected all versions; fixed in 0.4.0
- apache-libcloud (PyPI): affected all versions; fixed in 0.4.0
- apache-libcloud (PyPI): affected all versions; fixed in 0.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-4340/ (Markdown: https://insights.sbomify.com/CVE-2010-4340/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-4340
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-4340
- OSV: https://osv.dev/vulnerability/CVE-2010-4340

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-4340/
Summaries are generated and may contain mistakes; the official description above is the record.
