# CVE-2010-4408: Apache Archiva does not require entry of the administrator's password at the time of modifying a user account

> Attackers can modify user accounts and gain privileges without re-entering the administrator password, leveraging CSRF or unattended sessions.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Dec 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-5p54-jj38-3hxj

## What is CVE-2010-4408?

CVE-2010-4408 is a medium-severity missing authorization vulnerability in n/a, published on 6 Dec 2010. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Apache Archiva 1.0 through 1.0.3, 1.1 through 1.1.4, 1.2 through 1.2.2, and 1.3 through 1.3.1 does not require entry of the administrator's password at the time of modifying a user account, which makes it easier for context-dependent attackers to gain privileges by leveraging a (1) unattended workstation or (2) cross-site request forgery (CSRF) vulnerability, a related issue to CVE-2010-3449.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2010-4408?

2 open source packages ship an affected version, including org.apache.archiva:archiva. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.archiva:archiva` | Maven | From 1.0 | 1.3.2 |
| `org.apache.archiva:archiva` | Maven | From 1.0 | 1.3.2 |

Products: Apache Archiva.

## How do I fix CVE-2010-4408?

Upgrade org.apache.archiva:archiva to 1.3.2 or later.

## Is CVE-2010-4408 being exploited?

There is no known exploitation of CVE-2010-4408 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-2251](https://insights.sbomify.com/CVE-2013-2251/): Apache Struts Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2016-4469](https://insights.sbomify.com/CVE-2016-4469/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2017-5657](https://insights.sbomify.com/CVE-2017-5657/): Apache Archiva vulnerable to Cross Site Request Forgery (high 8.0)
- [CVE-2024-27138](https://insights.sbomify.com/CVE-2024-27138/): Apache Archiva: disabling user registration is not effective (high 7.5)
- [CVE-2024-27139](https://insights.sbomify.com/CVE-2024-27139/): Apache Archiva: incorrect authentication potentially leading to account takeover (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-4408 and fix it if it is affected.

What it is: CVE-2010-4408 is a medium-severity missing authorization vulnerability in n/a, published on 6 Dec 2010. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2010-4408 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.archiva:archiva (Maven): affected from 1.0; fixed in 1.3.2
- org.apache.archiva:archiva (Maven): affected from 1.0; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-4408/ (Markdown: https://insights.sbomify.com/CVE-2010-4408/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-4408
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-4408
- OSV: https://osv.dev/vulnerability/CVE-2010-4408

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-4408/
Summaries are generated and may contain mistakes; the official description above is the record.
