{"answers":{"affected":"2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2010-4481 in the wild and no public exploit code.","fix":"Upgrade phpmyadmin/phpmyadmin to 3.4.0-beta1 or later.","what":"CVE-2010-4481 is a medium-severity authentication bypass vulnerability in Phpmyadmin Phpmyadmin, published on 17 Dec 2010. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2010-4481 and fix it if it is affected.\n\nWhat it is: CVE-2010-4481 is a medium-severity authentication bypass vulnerability in Phpmyadmin Phpmyadmin, published on 17 Dec 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2010-4481 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected all versions; fixed in 3.4.0-beta1\n- phpmyadmin/phpmyadmin (Packagist): affected all versions; fixed in 3.4.0-beta1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-4481/ (Markdown: https://insights.sbomify.com/CVE-2010-4481/index.md)","id":"CVE-2010-4481","markdown":"https://insights.sbomify.com/CVE-2010-4481/index.md","name":"CVE-2010-4481","record":{"aliases":["DEBIAN-CVE-2010-4481","GHSA-gmc7-jvv7-w245"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Database administration tool","requires_auth":"none","summary":"Remote attackers can bypass authentication and access sensitive information by directly requesting phpinfo.php in phpMyAdmin.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"phpMyAdmin before 3.4.0-beta1 allows remote attackers to bypass authentication and obtain sensitive information via a direct request to phpinfo.php, which calls the phpinfo function.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpMyAdmin allows remote attackers to bypass authentication and obtain sensitive information","id":"CVE-2010-4481","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyadmin:phpmyadmin","products":["phpmyadmin:phpmyadmin"],"type":"auth_bypass","year":"2010"},"n_packages":2,"n_references":9,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2010-4482"},"packages":[{"ecosystem":"Packagist","fixed":["3.4.0-beta1"],"introduced":["0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-gmc7-jvv7-w245"},{"ecosystem":"Packagist","fixed":["3.4.0-beta1"],"introduced":["0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-gmc7-jvv7-w245"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2010-4480"},"products":["n/a"],"published":"2010-12-17","related":[{"cvss_score":10,"headline":"Misconfiguration in n/a","id":"CVE-2008-7251","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"phpMyAdmin unsafely handles temporary files","id":"CVE-2008-7252","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2007-0203","kev_date_added":null,"published":"2007-01-11"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2004-1147","kev_date_added":null,"published":"2004-12-15"},{"cvss_score":9.8,"headline":"phpmyadmin contains SQL Injection vulnerability","id":"CVE-2020-22452","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-11768","kev_date_added":null,"published":"2019-06-05"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-6798","kev_date_added":null,"published":"2019-01-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can bypass authentication and access sensitive information by directly requesting phpinfo.php in phpMyAdmin.","url":"https://insights.sbomify.com/CVE-2010-4481/"}