# CVE-2010-4481: phpMyAdmin allows remote attackers to bypass authentication and obtain sensitive information

> Remote attackers can bypass authentication and access sensitive information by directly requesting phpinfo.php in phpMyAdmin.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2010
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2010-4481, GHSA-gmc7-jvv7-w245

## What is CVE-2010-4481?

CVE-2010-4481 is a medium-severity authentication bypass vulnerability in Phpmyadmin Phpmyadmin, published on 17 Dec 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

phpMyAdmin before 3.4.0-beta1 allows remote attackers to bypass authentication and obtain sensitive information via a direct request to phpinfo.php, which calls the phpinfo function.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2010-4481?

2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | All versions | 3.4.0-beta1 |
| `phpmyadmin/phpmyadmin` | Packagist | All versions | 3.4.0-beta1 |

Products: Phpmyadmin Phpmyadmin.

## How do I fix CVE-2010-4481?

Upgrade phpmyadmin/phpmyadmin to 3.4.0-beta1 or later.

## Is CVE-2010-4481 being exploited?

There is no known exploitation of CVE-2010-4481 in the wild and no public exploit code.

## Other vulnerabilities in Phpmyadmin Phpmyadmin

- [CVE-2008-7251](https://insights.sbomify.com/CVE-2008-7251/): Misconfiguration in n/a (critical 10.0)
- [CVE-2008-7252](https://insights.sbomify.com/CVE-2008-7252/): phpMyAdmin unsafely handles temporary files (critical 10.0)
- [CVE-2007-0203](https://insights.sbomify.com/CVE-2007-0203/): Other in n/a (critical 10.0)
- [CVE-2004-1147](https://insights.sbomify.com/CVE-2004-1147/): Command injection in n/a (critical 10.0)
- [CVE-2020-22452](https://insights.sbomify.com/CVE-2020-22452/): phpmyadmin contains SQL Injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-4481 and fix it if it is affected.

What it is: CVE-2010-4481 is a medium-severity authentication bypass vulnerability in Phpmyadmin Phpmyadmin, published on 17 Dec 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2010-4481 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected all versions; fixed in 3.4.0-beta1
- phpmyadmin/phpmyadmin (Packagist): affected all versions; fixed in 3.4.0-beta1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-4481/ (Markdown: https://insights.sbomify.com/CVE-2010-4481/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-4481
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-4481
- OSV: https://osv.dev/vulnerability/CVE-2010-4481

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-4481/
Summaries are generated and may contain mistakes; the official description above is the record.
