{"answers":{"affected":"2 open source packages ship an affected version, including impresscms/impresscms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2010-4616 in the wild and no public exploit code.","fix":"Upgrade impresscms/impresscms to 1.2.4 or later.","what":"CVE-2010-4616 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Dec 2010. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2010-4616 and fix it if it is affected.\n\nWhat it is: CVE-2010-4616 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Dec 2010. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2010-4616 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- impresscms/impresscms (Packagist): affected all versions; fixed in 1.2.4\n- impresscms/impresscms (Packagist): affected all versions; fixed in 1.2.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-4616/ (Markdown: https://insights.sbomify.com/CVE-2010-4616/index.md)","id":"CVE-2010-4616","markdown":"https://insights.sbomify.com/CVE-2010-4616/index.md","name":"CVE-2010-4616","record":{"aliases":["GHSA-39vm-rvwh-q86j"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"ImpressCMS","requires_auth":"low_privilege","summary":"Remote attackers can inject arbitrary web script or HTML via the quicksearch_ContentContent parameter in ImpressCMS, potentially leading to session hijacking or malicious actions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"impresscms","vendor":"impresscms"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in modules/content/admin/content.php in ImpressCMS 1.2.3 Final, and possibly other versions before 1.2.4, allows remote attackers to inject arbitrary web script or HTML via the quicksearch_ContentContent parameter.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ImpressCMS Cross-site Scripting vulnerability via quicksearch_ContentContent parameter","id":"CVE-2010-4616","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2010"},"n_packages":2,"n_references":4,"next":{"headline":"Path traversal in n/a","id":"CVE-2010-4617"},"packages":[{"ecosystem":"Packagist","fixed":["1.2.4"],"introduced":["0"],"last_affected":[],"package":"impresscms/impresscms","purl":null,"source":"GHSA-39vm-rvwh-q86j"},{"ecosystem":"Packagist","fixed":["1.2.4"],"introduced":["0"],"last_affected":[],"package":"impresscms/impresscms","purl":"pkg:composer/impresscms/impresscms","source":"GHSA-39vm-rvwh-q86j"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2010-4615"},"products":["n/a"],"published":"2010-12-29","related":[{"cvss_score":10,"headline":"Multiple unspecified vulnerabilities in ImpressCMS 1.0 have unknown impact and attack vectors, related to modules/admin.php and \"a few files","id":"CVE-2008-3453","kev_date_added":null,"published":"2008-08-04"},{"cvss_score":9.8,"headline":"SQL Injection in ImpressCMS","id":"CVE-2021-26599","kev_date_added":null,"published":"2022-03-28"},{"cvss_score":9.8,"headline":"Type Confusion in ImpressCMS","id":"CVE-2021-26600","kev_date_added":null,"published":"2022-03-28"},{"cvss_score":9.8,"headline":"Path Traversal in ImpressCMS","id":"CVE-2022-24977","kev_date_added":null,"published":"2022-02-13"},{"cvss_score":9.3,"headline":"ImpressCMS 1.4.4 - Unrestricted File Upload","id":"CVE-2022-50912","kev_date_added":null,"published":"2026-01-13"},{"cvss_score":8.1,"headline":"Path Traversal in ImpressCMS","id":"CVE-2021-26601","kev_date_added":null,"published":"2022-03-28"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2010-4271","kev_date_added":null,"published":"2010-11-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via the quicksearch_ContentContent parameter in ImpressCMS, potentially leading to session hijacking or malicious actions.","url":"https://insights.sbomify.com/CVE-2010-4616/"}