# CVE-2010-4616: ImpressCMS Cross-site Scripting vulnerability via quicksearch_ContentContent parameter

> Remote attackers can inject arbitrary web script or HTML via the quicksearch_ContentContent parameter in ImpressCMS, potentially leading to session hijacking or malicious actions.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Dec 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-39vm-rvwh-q86j

## What is CVE-2010-4616?

CVE-2010-4616 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Dec 2010. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in modules/content/admin/content.php in ImpressCMS 1.2.3 Final, and possibly other versions before 1.2.4, allows remote attackers to inject arbitrary web script or HTML via the quicksearch_ContentContent parameter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2010-4616?

2 open source packages ship an affected version, including impresscms/impresscms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `impresscms/impresscms` | Packagist | All versions | 1.2.4 |
| `impresscms/impresscms` | Packagist | All versions | 1.2.4 |

Products: Impresscms Impresscms.

## How do I fix CVE-2010-4616?

Upgrade impresscms/impresscms to 1.2.4 or later.

## Is CVE-2010-4616 being exploited?

There is no known exploitation of CVE-2010-4616 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2008-3453](https://insights.sbomify.com/CVE-2008-3453/): Multiple unspecified vulnerabilities in ImpressCMS 1.0 have unknown impact and attack vectors, related to modules/admin.php and "a few files (critical 10.0)
- [CVE-2021-26599](https://insights.sbomify.com/CVE-2021-26599/): SQL Injection in ImpressCMS (critical 9.8)
- [CVE-2021-26600](https://insights.sbomify.com/CVE-2021-26600/): Type Confusion in ImpressCMS (critical 9.8)
- [CVE-2022-24977](https://insights.sbomify.com/CVE-2022-24977/): Path Traversal in ImpressCMS (critical 9.8)
- [CVE-2022-50912](https://insights.sbomify.com/CVE-2022-50912/): ImpressCMS 1.4.4 - Unrestricted File Upload (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-4616 and fix it if it is affected.

What it is: CVE-2010-4616 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Dec 2010. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2010-4616 in the wild and no public exploit code.

Affected packages and fixed versions:
- impresscms/impresscms (Packagist): affected all versions; fixed in 1.2.4
- impresscms/impresscms (Packagist): affected all versions; fixed in 1.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-4616/ (Markdown: https://insights.sbomify.com/CVE-2010-4616/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-4616
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-4616
- OSV: https://osv.dev/vulnerability/CVE-2010-4616

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-4616/
Summaries are generated and may contain mistakes; the official description above is the record.
