# CVE-2010-4879: DOMPDF Remote File Inclusion Vulnerability

> Remote attackers can execute arbitrary PHP code via a URL in the input_file parameter of dompdf.php.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2011
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2010-4879, GHSA-48r9-4v93-x4wh

## What is CVE-2010-4879?

CVE-2010-4879 is a high-severity code injection vulnerability in n/a, published on 7 Oct 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PHP remote file inclusion vulnerability in dompdf.php in dompdf 0.6.0 beta1 allows remote attackers to execute arbitrary PHP code via a URL in the input_file parameter.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2010-4879?

2 open source packages ship an affected version, including dompdf/dompdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dompdf/dompdf` | Packagist | From 0.6 | 0.6.1 |
| `dompdf/dompdf` | Packagist | From 0.6 | 0.6.1 |

Products: Digitaljunkies Dompdf.

## How do I fix CVE-2010-4879?

Upgrade dompdf/dompdf to 0.6.1 or later.

## Is CVE-2010-4879 being exploited?

There is no known exploitation of CVE-2010-4879 in the wild and no public exploit code.

Public exploit code:

- dompdf 0.6.0 beta1 - Remote File Inclusion (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-4879 and fix it if it is affected.

What it is: CVE-2010-4879 is a high-severity code injection vulnerability in n/a, published on 7 Oct 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2010-4879 in the wild and no public exploit code.

Affected packages and fixed versions:
- dompdf/dompdf (Packagist): affected from 0.6; fixed in 0.6.1
- dompdf/dompdf (Packagist): affected from 0.6; fixed in 0.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-4879/ (Markdown: https://insights.sbomify.com/CVE-2010-4879/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-4879
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-4879
- OSV: https://osv.dev/vulnerability/CVE-2010-4879

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-4879/
Summaries are generated and may contain mistakes; the official description above is the record.
