CVE-2010-5100 TYPO3 Cross-Site Scripting vulnerability in the Install Tool

Low 3.5 Published Updated

Authenticated users can inject arbitrary scripts into the TYPO3 Install Tool, potentially leading to code execution or account takeover.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2010-5100?

CVE-2010-5100 is a low-severity cross-site scripting vulnerability in Typo3 Typo3, published on 21 May 2012. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Multiple cross-site scripting (XSS) vulnerabilities in the Install Tool in TYPO3 4.2.x before 4.2.16, 4.3.x before 4.3.9, and 4.4.x before 4.4.5 allow remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79

Which versions are affected by CVE-2010-5100?

6 open source packages ship an affected version, including typo3/cms-install. It affects 1 product.

PackageAffectedFixed in
typo3/cms-install PackagistFrom 4.2.04.2.16
typo3/cms-install PackagistFrom 4.2.04.2.16
typo3/cms-install PackagistFrom 4.3.04.3.9
typo3/cms-install PackagistFrom 4.3.04.3.9
typo3/cms-install PackagistFrom 4.4.04.4.5
typo3/cms-install PackagistFrom 4.4.04.4.5

Products include Typo3 Typo3.

How do I fix CVE-2010-5100?

Upgrade typo3/cms-install to a fixed version for your release line: 4.2.16, 4.3.9 or 4.4.5.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2010-5100 being exploited?

There is no known exploitation of CVE-2010-5100 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as CVE-2012-2345, GHSA-9hh2-8cw6-hfv7.

Is CVE-2010-5100 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free