{"answers":{"affected":"8 open source packages ship an affected version, including org.webjars.npm:jquery-ui, jQuery.UI.Combined and jquery-ui-rails. It affects 6 products.","exploited":"There is no known exploitation of CVE-2010-5312 in the wild and no public exploit code.","fix":"Upgrade org.webjars.npm:jquery-ui to 1.10.0 or later.","what":"CVE-2010-5312 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 24 Nov 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2010-5312 and fix it if it is affected.\n\nWhat it is: CVE-2010-5312 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 24 Nov 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2010-5312 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.webjars.npm:jquery-ui (Maven): affected from 1.7.0; fixed in 1.10.0\n- org.webjars.npm:jquery-ui (Maven): affected from 1.7.0; fixed in 1.10.0\n- jQuery.UI.Combined (NuGet): affected from 1.7.0; fixed in 1.10.0\n- jQuery.UI.Combined (NuGet): affected from 1.7.0; fixed in 1.10.0\n- jquery-ui-rails (RubyGems): affected all versions; fixed in 4.0.0\n- jquery-ui-rails (RubyGems): affected all versions; fixed in 4.0.0\n- jquery-ui (npm): affected from 1.7.0; fixed in 1.10.0\n- jquery-ui (npm): affected from 1.7.0; fixed in 1.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-5312/ (Markdown: https://insights.sbomify.com/CVE-2010-5312/index.md)","id":"CVE-2010-5312","markdown":"https://insights.sbomify.com/CVE-2010-5312/index.md","name":"CVE-2010-5312","record":{"aliases":["CLEANSTART-2024-FV11333","DEBIAN-CVE-2010-5312","DLA-258-1","DSA-3249-1","GHSA-wcm2-9c89-wmfm","MGASA-2014-0559"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"jQuery UI library","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via the title option in the jQuery UI Dialog widget, potentially leading to code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"drill","vendor":"apache"},{"product":"debian_linux","vendor":"debian"},{"product":"drupal","vendor":"drupal"},{"product":"fedora","vendor":"fedoraproject"},{"product":"jquery_ui","vendor":"jqueryui"},{"product":"snapcenter","vendor":"netapp"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in jquery.ui.dialog.js in the Dialog widget in jQuery UI before 1.10.0 allows remote attackers to inject arbitrary web script or HTML via the title option.","ecosystems":["Maven","NuGet","RubyGems","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in jquery-ui","id":"CVE-2010-5312","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"debian:debian_linux","products":["debian:debian_linux","drupal:drupal","fedoraproject:fedora","netapp:snapcenter"],"type":"xss","year":"2010"},"n_packages":8,"n_references":19,"next":{"headline":"Race condition in n/a","id":"CVE-2010-5313"},"packages":[{"ecosystem":"Maven","fixed":["1.10.0"],"introduced":["1.7.0"],"last_affected":[],"package":"org.webjars.npm:jquery-ui","purl":null,"source":"GHSA-wcm2-9c89-wmfm"},{"ecosystem":"Maven","fixed":["1.10.0"],"introduced":["1.7.0"],"last_affected":[],"package":"org.webjars.npm:jquery-ui","purl":"pkg:maven/org.webjars.npm/jquery-ui","source":"GHSA-wcm2-9c89-wmfm"},{"ecosystem":"NuGet","fixed":["1.10.0"],"introduced":["1.7.0"],"last_affected":[],"package":"jQuery.UI.Combined","purl":null,"source":"GHSA-wcm2-9c89-wmfm"},{"ecosystem":"NuGet","fixed":["1.10.0"],"introduced":["1.7.0"],"last_affected":[],"package":"jQuery.UI.Combined","purl":"pkg:nuget/jQuery.UI.Combined","source":"GHSA-wcm2-9c89-wmfm"},{"ecosystem":"RubyGems","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"jquery-ui-rails","purl":null,"source":"GHSA-wcm2-9c89-wmfm"},{"ecosystem":"RubyGems","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"jquery-ui-rails","purl":"pkg:gem/jquery-ui-rails","source":"GHSA-wcm2-9c89-wmfm"},{"ecosystem":"npm","fixed":["1.10.0"],"introduced":["1.7.0"],"last_affected":[],"package":"jquery-ui","purl":null,"source":"GHSA-wcm2-9c89-wmfm"},{"ecosystem":"npm","fixed":["1.10.0"],"introduced":["1.7.0"],"last_affected":[],"package":"jquery-ui","purl":"pkg:npm/jquery-ui","source":"GHSA-wcm2-9c89-wmfm"}],"prev":{"headline":"Hardcoded credentials in n/a","id":"CVE-2010-5310"},"products":["n/a"],"published":"2014-11-24","related":[{"cvss_score":9.8,"headline":"Apache Drill: XXE Vulnerability in XML Format Reader","id":"CVE-2023-48362","kev_date_added":null,"published":"2024-07-24"},{"cvss_score":7.5,"headline":"Deserialization of untrusted data in FasterXML jackson-databind","id":"CVE-2019-14439","kev_date_added":null,"published":"2019-07-30"},{"cvss_score":5.4,"headline":"Apache Drill vulnerable to Cross-site Scripting","id":"CVE-2017-12630","kev_date_added":null,"published":"2017-12-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via the title option in the jQuery UI Dialog widget, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2010-5312/"}