# CVE-2010-5312: Cross-site Scripting in jquery-ui

> Remote attackers can inject arbitrary web script or HTML via the title option in the jQuery UI Dialog widget, potentially leading to code execution.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Nov 2014
- **Updated:** 7 Aug 2024
- **Also known as:** CLEANSTART-2024-FV11333, DEBIAN-CVE-2010-5312, DLA-258-1, DSA-3249-1, GHSA-wcm2-9c89-wmfm, MGASA-2014-0559

## What is CVE-2010-5312?

CVE-2010-5312 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 24 Nov 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in jquery.ui.dialog.js in the Dialog widget in jQuery UI before 1.10.0 allows remote attackers to inject arbitrary web script or HTML via the title option.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2010-5312?

8 open source packages ship an affected version, including org.webjars.npm:jquery-ui, jQuery.UI.Combined and jquery-ui-rails. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.webjars.npm:jquery-ui` | Maven | From 1.7.0 | 1.10.0 |
| `org.webjars.npm:jquery-ui` | Maven | From 1.7.0 | 1.10.0 |
| `jQuery.UI.Combined` | NuGet | From 1.7.0 | 1.10.0 |
| `jQuery.UI.Combined` | NuGet | From 1.7.0 | 1.10.0 |
| `jquery-ui-rails` | RubyGems | All versions | 4.0.0 |
| `jquery-ui-rails` | RubyGems | All versions | 4.0.0 |
| `jquery-ui` | npm | From 1.7.0 | 1.10.0 |
| `jquery-ui` | npm | From 1.7.0 | 1.10.0 |

Products: Apache Drill, Debian Debian Linux, Drupal Drupal, Fedoraproject Fedora, Jqueryui Jquery Ui, Netapp Snapcenter.

## How do I fix CVE-2010-5312?

Upgrade org.webjars.npm:jquery-ui to 1.10.0 or later.

## Is CVE-2010-5312 being exploited?

There is no known exploitation of CVE-2010-5312 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2023-48362](https://insights.sbomify.com/CVE-2023-48362/): Apache Drill: XXE Vulnerability in XML Format Reader (critical 9.8)
- [CVE-2019-14439](https://insights.sbomify.com/CVE-2019-14439/): Deserialization of untrusted data in FasterXML jackson-databind (high 7.5)
- [CVE-2017-12630](https://insights.sbomify.com/CVE-2017-12630/): Apache Drill vulnerable to Cross-site Scripting (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-5312 and fix it if it is affected.

What it is: CVE-2010-5312 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 24 Nov 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2010-5312 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.webjars.npm:jquery-ui (Maven): affected from 1.7.0; fixed in 1.10.0
- org.webjars.npm:jquery-ui (Maven): affected from 1.7.0; fixed in 1.10.0
- jQuery.UI.Combined (NuGet): affected from 1.7.0; fixed in 1.10.0
- jQuery.UI.Combined (NuGet): affected from 1.7.0; fixed in 1.10.0
- jquery-ui-rails (RubyGems): affected all versions; fixed in 4.0.0
- jquery-ui-rails (RubyGems): affected all versions; fixed in 4.0.0
- jquery-ui (npm): affected from 1.7.0; fixed in 1.10.0
- jquery-ui (npm): affected from 1.7.0; fixed in 1.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-5312/ (Markdown: https://insights.sbomify.com/CVE-2010-5312/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-5312
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-5312
- OSV: https://osv.dev/vulnerability/CVE-2010-5312

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-5312/
Summaries are generated and may contain mistakes; the official description above is the record.
