CVE-2011-0013 Improper Neutralization of Input During Web Page Generation in Apache Tomcat
Remote attackers can inject arbitrary web script or HTML into the Apache Tomcat HTML Manager Interface, potentially stealing user data or hijacking sessions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2011-0013?
CVE-2011-0013 is a medium-severity cross-site scripting vulnerability in Apache Tomcat, published on 18 Feb 2011. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in the HTML Manager Interface in Apache Tomcat 5.5 before 5.5.32, 6.0 before 6.0.30, and 7.0 before 7.0.6 allow remote attackers to inject arbitrary web script or HTML, as demonstrated via the display-name tag.
Weakness: CWE-79
Which versions are affected by CVE-2011-0013?
6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.32 |
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.32 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.30 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.30 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.6 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.6 |
Products include Apache Tomcat.
How do I fix CVE-2011-0013?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 5.5.32, 6.0.30 or 7.0.6.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2011-0013 being exploited?
There is no known exploitation of CVE-2011-0013 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-3p86-xgrq-m6p6.