CVE-2011-0447 actionpack Cross-Site Request Forgery vulnerability

Medium 6.8 Published Updated

Remote attackers can bypass CSRF protections in Ruby on Rails applications by forging AJAX or API requests using specific browser plugins and redirects.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2011-0447?

CVE-2011-0447 is a medium-severity vulnerability in Rubyonrails Rails, published on 14 Feb 2011. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Ruby on Rails 2.1.x, 2.2.x, and 2.3.x before 2.3.11, and 3.x before 3.0.4, does not properly validate HTTP requests that contain an X-Requested-With header, which makes it easier for remote attackers to conduct cross-site request forgery (CSRF) attacks via forged (1) AJAX or (2) API requests that leverage "combinations of browser plugins and HTTP redirects," a related issue to CVE-2011-0696.

Weakness: CWE-352

Which versions are affected by CVE-2011-0447?

4 open source packages ship an affected version, including actionpack. It affects 1 product.

PackageAffectedFixed in
actionpack RubyGemsFrom 2.1.02.3.11
actionpack RubyGemsFrom 2.1.02.3.11
actionpack RubyGemsFrom 3.0.03.0.4
actionpack RubyGemsFrom 3.0.03.0.4

Products include Rubyonrails Rails.

How do I fix CVE-2011-0447?

Upgrade actionpack to a fixed version for your release line: 2.3.11 or 3.0.4.

Is CVE-2011-0447 being exploited?

There is no known exploitation of CVE-2011-0447 in the wild and no public exploit code.

All Rubyonrails Rails vulnerabilities

Sources

Also known as DEBIAN-CVE-2011-0447, GHSA-24fg-p96v-hxh8.

Is CVE-2011-0447 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free