# CVE-2011-0448: activerecord vulnerable to SQL Injection

> Remote attackers can execute SQL injection attacks via non-numeric arguments to the limit function in Ruby on Rails.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Feb 2011
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-jmm9-2p29-vh2w

## What is CVE-2011-0448?

CVE-2011-0448 is a high-severity SQL injection vulnerability in Rubyonrails Rails, published on 21 Feb 2011. It can be exploited over the network, with no action from the victim.

### Official description

Ruby on Rails 3.0.x before 3.0.4 does not ensure that arguments to the limit function specify integer values, which makes it easier for remote attackers to conduct SQL injection attacks via a non-numeric argument.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2011-0448?

2 open source packages ship an affected version, including activerecord. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activerecord` | RubyGems | From 3.0.0 | 3.0.4 |
| `activerecord` | RubyGems | From 3.0.0 | 3.0.4 |

Products: Rubyonrails Rails.

## How do I fix CVE-2011-0448?

Upgrade activerecord to 3.0.4 or later.

## Is CVE-2011-0448 being exploited?

There is no known exploitation of CVE-2011-0448 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-0448 and fix it if it is affected.

What it is: CVE-2011-0448 is a high-severity SQL injection vulnerability in Rubyonrails Rails, published on 21 Feb 2011. It can be exploited over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-0448 in the wild and no public exploit code.

Affected packages and fixed versions:
- activerecord (RubyGems): affected from 3.0.0; fixed in 3.0.4
- activerecord (RubyGems): affected from 3.0.0; fixed in 3.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-0448/ (Markdown: https://insights.sbomify.com/CVE-2011-0448/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-0448
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-0448
- OSV: https://osv.dev/vulnerability/CVE-2011-0448

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-0448/
Summaries are generated and may contain mistakes; the official description above is the record.
