{"answers":{"affected":"2 open source packages ship an affected version, including ec-cube/ec-cube. It affects 1 product.","exploited":"There is no known exploitation of CVE-2011-0451 in the wild and no public exploit code.","fix":"Upgrade ec-cube/ec-cube to 2.4.4 or later.","what":"CVE-2011-0451 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Feb 2011. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2011-0451 and fix it if it is affected.\n\nWhat it is: CVE-2011-0451 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Feb 2011. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2011-0451 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ec-cube/ec-cube (Packagist): affected all versions; fixed in 2.4.4\n- ec-cube/ec-cube (Packagist): affected all versions; fixed in 2.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-0451/ (Markdown: https://insights.sbomify.com/CVE-2011-0451/index.md)","id":"CVE-2011-0451","markdown":"https://insights.sbomify.com/CVE-2011-0451/index.md","name":"CVE-2011-0451","record":{"aliases":["GHSA-wgvv-5396-ggvj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"EC-CUBE e-commerce","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML into EC-CUBE templates, potentially compromising user sessions or data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[{"product":"ec-cube","vendor":"lockon"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in (1) data/Smarty/templates/default/list.tpl and (2) data/Smarty/templates/default/campaign/bloc/cart_tag.tpl in EC-CUBE before 2.4.4 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"EC-CUBE XSS Vulnerabilities","id":"CVE-2011-0451","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2011"},"n_packages":2,"n_references":7,"next":{"headline":"Path traversal in n/a","id":"CVE-2011-0452"},"packages":[{"ecosystem":"Packagist","fixed":["2.4.4"],"introduced":["0"],"last_affected":[],"package":"ec-cube/ec-cube","purl":null,"source":"GHSA-wgvv-5396-ggvj"},{"ecosystem":"Packagist","fixed":["2.4.4"],"introduced":["0"],"last_affected":[],"package":"ec-cube/ec-cube","purl":"pkg:composer/ec-cube/ec-cube","source":"GHSA-wgvv-5396-ggvj"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2011-0450"},"products":["n/a"],"published":"2011-02-03","related":[{"cvss_score":9.1,"headline":"EC-CUBE vulnerable to authorization bypass","id":"CVE-2014-0808","kev_date_added":null,"published":"2014-01-22"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2016-1201","kev_date_added":null,"published":"2016-04-30"},{"cvss_score":8.1,"headline":"Other in EC-CUBE","id":"CVE-2018-0564","kev_date_added":null,"published":"2018-04-20"},{"cvss_score":7.5,"headline":"Code injection in n/a","id":"CVE-2013-3651","kev_date_added":null,"published":"2013-06-29"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2011-3988","kev_date_added":null,"published":"2011-10-21"},{"cvss_score":6.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2013-5993","kev_date_added":null,"published":"2013-11-21"},{"cvss_score":6.4,"headline":"Business logic in n/a","id":"CVE-2014-0807","kev_date_added":null,"published":"2014-01-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML into EC-CUBE templates, potentially compromising user sessions or data.","url":"https://insights.sbomify.com/CVE-2011-0451/"}