{"answers":{"affected":"2 open source packages ship an affected version, including puppet. It affects 1 product.","exploited":"There is no known exploitation of CVE-2011-0528 in the wild and no public exploit code.","fix":"Upgrade puppet to 2.6.4 or later.","what":"CVE-2011-0528 is a medium-severity missing authorization vulnerability in n/a, published on 17 Feb 2014. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2011-0528 and fix it if it is affected.\n\nWhat it is: CVE-2011-0528 is a medium-severity missing authorization vulnerability in n/a, published on 17 Feb 2014. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2011-0528 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- puppet (RubyGems): affected from 2.6.0; fixed in 2.6.4\n- puppet (RubyGems): affected from 2.6.0; fixed in 2.6.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-0528/ (Markdown: https://insights.sbomify.com/CVE-2011-0528/index.md)","id":"CVE-2011-0528","markdown":"https://insights.sbomify.com/CVE-2011-0528/index.md","name":"CVE-2011-0528","record":{"aliases":["DEBIAN-CVE-2011-0528","GHSA-9pvx-fwwh-w289"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Puppet configuration management","requires_auth":"low_privilege","summary":"Remote authenticated Puppet nodes can read or modify resources of other nodes due to improper access restrictions.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"puppet","vendor":"puppet"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:S/C:P/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"Puppet 2.6.0 through 2.6.3 does not properly restrict access to node resources, which allows remote authenticated Puppet nodes to read or modify the resources of other nodes via unspecified vectors.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Puppet does not properly restrict access to node resources","id":"CVE-2011-0528","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"missing_authorization","year":"2011"},"n_packages":2,"n_references":4,"next":{"headline":"Weborf before 0.12.5 is affected by a Denial of Service (DOS) due to malformed fields in HTTP.","id":"CVE-2011-0529"},"packages":[{"ecosystem":"RubyGems","fixed":["2.6.4"],"introduced":["2.6.0"],"last_affected":[],"package":"puppet","purl":null,"source":"GHSA-9pvx-fwwh-w289"},{"ecosystem":"RubyGems","fixed":["2.6.4"],"introduced":["2.6.0"],"last_affected":[],"package":"puppet","purl":"pkg:gem/puppet","source":"GHSA-9pvx-fwwh-w289"}],"prev":{"headline":"Auth bypass in n/a","id":"CVE-2011-0527"},"products":["n/a"],"published":"2014-02-17","related":[{"cvss_score":9.8,"headline":"Puppet Improper Access Control","id":"CVE-2016-2785","kev_date_added":null,"published":"2016-06-10"},{"cvss_score":8.8,"headline":"SQL injection in Puppet DB","id":"CVE-2021-27021","kev_date_added":null,"published":"2021-07-20"},{"cvss_score":8.8,"headline":"Privilege escalation in Puppet Enterprise and Puppet Agent","id":"CVE-2018-6513","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.8,"headline":"Privilege escalation in Puppet Agent","id":"CVE-2018-6514","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.8,"headline":"Code injection in Puppet Agent","id":"CVE-2018-6515","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.5,"headline":"Puppet Improper Input Validation vulnerability","id":"CVE-2013-1655","kev_date_added":null,"published":"2013-03-20"},{"cvss_score":6.9,"headline":"Puppet Privilege Escallation","id":"CVE-2012-1053","kev_date_added":null,"published":"2012-05-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote authenticated Puppet nodes can read or modify resources of other nodes due to improper access restrictions.","url":"https://insights.sbomify.com/CVE-2011-0528/"}