# CVE-2011-0533: Apache Continuum and Archiva vulnerable to Cross-site Scripting

> Remote attackers can inject arbitrary web script or HTML into Apache Continuum and Archiva via crafted parameters, potentially compromising user sessions.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Feb 2011
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-7382-fv7p-v9v3

## What is CVE-2011-0533?

CVE-2011-0533 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Feb 2011. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in Apache Continuum 1.1 through 1.2.3.1, 1.3.6, and 1.4.0 Beta; and Archiva 1.3.0 through 1.3.3 and 1.0 through 1.22 allows remote attackers to inject arbitrary web script or HTML via a crafted parameter, related to the autoIncludeParameters setting for the extremecomponents table.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2011-0533?

6 open source packages ship an affected version, including org.apache.continuum:continuum and org.apache.archiva:archiva. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.continuum:continuum` | Maven | All versions | None |
| `org.apache.continuum:continuum` | Maven | All versions | None |
| `org.apache.continuum:continuum` | Maven | From 1.1 | 1.3.7 |
| `org.apache.continuum:continuum` | Maven | From 1.1 | 1.3.7 |
| `org.apache.archiva:archiva` | Maven | From 1.0 | 1.3.4 |
| `org.apache.archiva:archiva` | Maven | From 1.0 | 1.3.4 |

Products: Apache Archiva, Apache Continuum.

## How do I fix CVE-2011-0533?

Upgrade org.apache.continuum:continuum to 1.3.7 or later.

## Is CVE-2011-0533 being exploited?

There is no known exploitation of CVE-2011-0533 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-2251](https://insights.sbomify.com/CVE-2013-2251/): Apache Struts Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2016-4469](https://insights.sbomify.com/CVE-2016-4469/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2017-5657](https://insights.sbomify.com/CVE-2017-5657/): Apache Archiva vulnerable to Cross Site Request Forgery (high 8.0)
- [CVE-2024-27138](https://insights.sbomify.com/CVE-2024-27138/): Apache Archiva: disabling user registration is not effective (high 7.5)
- [CVE-2024-27139](https://insights.sbomify.com/CVE-2024-27139/): Apache Archiva: incorrect authentication potentially leading to account takeover (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-0533 and fix it if it is affected.

What it is: CVE-2011-0533 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Feb 2011. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2011-0533 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.continuum:continuum (Maven): affected all versions; no fix listed
- org.apache.continuum:continuum (Maven): affected all versions; no fix listed
- org.apache.continuum:continuum (Maven): affected from 1.1; fixed in 1.3.7
- org.apache.continuum:continuum (Maven): affected from 1.1; fixed in 1.3.7
- org.apache.archiva:archiva (Maven): affected from 1.0; fixed in 1.3.4
- org.apache.archiva:archiva (Maven): affected from 1.0; fixed in 1.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-0533/ (Markdown: https://insights.sbomify.com/CVE-2011-0533/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-0533
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-0533
- OSV: https://osv.dev/vulnerability/CVE-2011-0533

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-0533/
Summaries are generated and may contain mistakes; the official description above is the record.
