{"answers":{"affected":"It affects 7 products.","exploited":"Yes. Attackers have exploited CVE-2011-0609 in the wild since at least 8 Jun 2022.","fix":"Apply the vendor's patch. US federal agencies must fix it by 22 Jun 2022.","what":"CVE-2011-0609 is a high-severity code injection vulnerability in Adobe Acrobat, published on 15 Mar 2011. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2011-0609 and fix it if it is affected.\n\nWhat it is: CVE-2011-0609 is a high-severity code injection vulnerability in Adobe Acrobat, published on 15 Mar 2011. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: Yes. Attackers have exploited CVE-2011-0609 in the wild since at least 8 Jun 2022.\n\nAffected product: Adobe Acrobat. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-0609/ (Markdown: https://insights.sbomify.com/CVE-2011-0609/index.md)","id":"CVE-2011-0609","markdown":"https://insights.sbomify.com/CVE-2011-0609/index.md","name":"CVE-2011-0609","record":{"aliases":["GHSA-g9g3-3gv9-454q","RHSA-2011:0372"],"analysis":{"component_type":"browser","fix_type":"patch","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Adobe Flash Player","requires_auth":"none","summary":"Remote attackers can execute arbitrary code or cause denial of service via crafted Flash content in Adobe Flash Player and Reader.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"adobe","cpe":[{"product":"acrobat","vendor":"adobe"},{"product":"acrobat_reader","vendor":"adobe"},{"product":"air","vendor":"adobe"},{"product":"flash_player","vendor":"adobe"},{"product":"chrome","vendor":"google"},{"product":"opensuse","vendor":"opensuse"},{"product":"linux_enterprise","vendor":"suse"}],"cvss":{"score":7.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"Unspecified vulnerability in Adobe Flash Player 10.2.154.13 and earlier on Windows, Mac OS X, Linux, and Solaris; 10.1.106.16 and earlier on Android; Adobe AIR 2.5.1 and earlier; and Authplay.dll (aka AuthPlayLib.bundle) in Adobe Reader and Acrobat 9.x through 9.4.2 and 10.x through 10.0.1 on Windows and Mac OS X, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via crafted Flash content, as demonstrated by a .swf file embedded in an Excel spreadsheet, and as exploited in the wild in March 2011.","ecosystems":["Red Hat:rhel_extras:5::client","Red Hat:rhel_extras:5::server","Red Hat:rhel_extras:6"],"exploits":{"exploitdb":1,"first_seen":"2011-03-15","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":0,"refs":[{"date":"2011-03-15","kind":"metasploit","ref":"exploit/windows/browser/adobe_flashplayer_avm","stars":null,"title":"Adobe Flash Player AVM Bytecode Verification Vulnerability"},{"date":"2011-03-23","kind":"exploitdb","ref":"17027","stars":null,"title":"Adobe Flash Player - AVM Bytecode Verification (Metasploit)"}],"tier":"exploited"},"has_fix":true,"headline":"Adobe Flash Player Unspecified","id":"CVE-2011-0609","indexable":true,"kev":{"dateAdded":"2022-06-08","dueDate":"2022-06-22","knownRansomwareCampaignUse":"Unknown","product":"Flash Player","requiredAction":"The impacted product is end-of-life and should be disconnected if still in use.","vendorProject":"Adobe","vulnerabilityName":"Adobe Flash Player Unspecified Vulnerability"},"kind":"cve","links":{"ecosystem":null,"product":"adobe:acrobat","products":["adobe:acrobat","adobe:acrobat_reader","adobe:air","adobe:flash_player","google:chrome","opensuse:opensuse","suse:linux_enterprise"],"type":"code_injection","year":"2011"},"n_packages":3,"n_references":22,"next":{"headline":"Memory corruption in n/a","id":"CVE-2011-0610"},"packages":[{"ecosystem":"Red Hat:rhel_extras:5::client","fixed":["0:10.2.153.1-1.el5"],"introduced":["0"],"last_affected":[],"package":"flash-plugin","purl":"pkg:rpm/redhat/flash-plugin","source":"RHSA-2011:0372"},{"ecosystem":"Red Hat:rhel_extras:5::server","fixed":["0:10.2.153.1-1.el5"],"introduced":["0"],"last_affected":[],"package":"flash-plugin","purl":"pkg:rpm/redhat/flash-plugin","source":"RHSA-2011:0372"},{"ecosystem":"Red Hat:rhel_extras:6","fixed":["0:10.2.153.1-1.el6"],"introduced":["0"],"last_affected":[],"package":"flash-plugin","purl":"pkg:rpm/redhat/flash-plugin","source":"RHSA-2011:0372"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2011-0608"},"products":["n/a"],"published":"2011-03-15","related":[{"cvss_score":9.6,"headline":"Adobe Acrobat and Reader Use-After-Free","id":"CVE-2021-28550","kev_date_added":"2021-11-03","published":"2021-09-02"},{"cvss_score":8.8,"headline":"Adobe Acrobat and Reader Heap-based Buffer Overflow","id":"CVE-2021-21017","kev_date_added":"2021-11-03","published":"2021-02-11"},{"cvss_score":8.8,"headline":"Adobe Reader and Acrobat Sandbox Bypass","id":"CVE-2014-0546","kev_date_added":"2022-05-25","published":"2014-08-12"},{"cvss_score":8.8,"headline":"Adobe Reader and Acrobat Use-After-Free","id":"CVE-2014-0496","kev_date_added":"2022-03-03","published":"2014-01-15"},{"cvss_score":8.8,"headline":"Adobe Reader and Acrobat Memory Corruption","id":"CVE-2013-3346","kev_date_added":"2022-03-03","published":"2013-08-30"},{"cvss_score":8.8,"headline":"Adobe Reader and Acrobat Arbitrary Integer Overflow","id":"CVE-2013-2729","kev_date_added":"2022-03-28","published":"2013-05-16"},{"cvss_score":8.8,"headline":"Adobe Reader and Acrobat Universal 3D Memory Corruption","id":"CVE-2011-2462","kev_date_added":"2022-06-08","published":"2011-12-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"open","licence":"CC0 1.0","name":"CISA KEV"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":"no","exploitation":"active","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-10-22","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code or cause denial of service via crafted Flash content in Adobe Flash Player and Reader.","url":"https://insights.sbomify.com/CVE-2011-0609/"}