# CVE-2011-0698: Directory traversal in Django

> Remote attackers can read or execute files on Windows systems via directory traversal in Django session cookies.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Feb 2011
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-7g9h-c88w-r7h2, PYSEC-2011-12

## What is CVE-2011-0698?

CVE-2011-0698 is a high-severity path traversal vulnerability in Djangoproject Django, published on 14 Feb 2011. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Directory traversal vulnerability in Django 1.1.x before 1.1.4 and 1.2.x before 1.2.5 on Windows might allow remote attackers to read or execute files via a / (slash) character in a key in a session cookie, related to session replays.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2011-0698?

5 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | From 1.1 | 1.1.4, 1.2.5 |
| `django` | PyPI | From 1.1 | 1.1.4 |
| `django` | PyPI | From 1.2 | 1.2.5 |
| `Django` | PyPI | From 1.1 | 1.1.4 |
| `Django` | PyPI | From 1.2 | 1.2.5 |

Products: Djangoproject Django.

## How do I fix CVE-2011-0698?

Upgrade django to a fixed version for your release line: 1.1.4 or 1.2.5.

## Is CVE-2011-0698 being exploited?

There is no known exploitation of CVE-2011-0698 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-0698 and fix it if it is affected.

What it is: CVE-2011-0698 is a high-severity path traversal vulnerability in Djangoproject Django, published on 14 Feb 2011. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-0698 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected from 1.1; fixed in 1.1.4, 1.2.5
- django (PyPI): affected from 1.1; fixed in 1.1.4
- django (PyPI): affected from 1.2; fixed in 1.2.5
- Django (PyPI): affected from 1.1; fixed in 1.1.4
- Django (PyPI): affected from 1.2; fixed in 1.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-0698/ (Markdown: https://insights.sbomify.com/CVE-2011-0698/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-0698
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-0698
- OSV: https://osv.dev/vulnerability/CVE-2011-0698

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-0698/
Summaries are generated and may contain mistakes; the official description above is the record.
