{"answers":{"affected":"3 open source packages ship an affected version, including loggerhead. It affects 1 product.","exploited":"There is no known exploitation of CVE-2011-0728 in the wild and no public exploit code.","fix":"Upgrade loggerhead to 1.18.1 or later.","what":"CVE-2011-0728 is a low-severity cross-site scripting vulnerability in n/a, published on 29 Mar 2011. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2011-0728 and fix it if it is affected.\n\nWhat it is: CVE-2011-0728 is a low-severity cross-site scripting vulnerability in n/a, published on 29 Mar 2011. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2011-0728 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- loggerhead (PyPI): affected all versions; fixed in 1.18.1\n- loggerhead (PyPI): affected all versions; fixed in 1.18.1\n- loggerhead (PyPI): affected all versions; fixed in 1.18.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-0728/ (Markdown: https://insights.sbomify.com/CVE-2011-0728/index.md)","id":"CVE-2011-0728","markdown":"https://insights.sbomify.com/CVE-2011-0728/index.md","name":"CVE-2011-0728","record":{"aliases":["DEBIAN-CVE-2011-0728","GHSA-qjmg-77xh-7mjw","PYSEC-2026-840"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Loggerhead web interface","requires_auth":"low_privilege","summary":"Authenticated users can inject arbitrary scripts via filenames in Loggerhead revision views, potentially compromising other users' sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"canonical","cpe":[{"product":"loggerhead","vendor":"michael_hudson-doyle"}],"cvss":{"score":3.5,"severity":"low","source":"nvd","vector":"AV:N/AC:M/Au:S/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in templatefunctions.py in Loggerhead before 1.18.1 allows remote authenticated users to inject arbitrary web script or HTML via a filename, which is not properly handled in a revision view.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Loggerhead XSS via filename","id":"CVE-2011-0728","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2011"},"n_packages":3,"n_references":12,"next":{"headline":"Missing authorization in n/a","id":"CVE-2011-0729"},"packages":[{"ecosystem":"PyPI","fixed":["1.18.1"],"introduced":["0"],"last_affected":[],"package":"loggerhead","purl":null,"source":"GHSA-qjmg-77xh-7mjw"},{"ecosystem":"PyPI","fixed":["1.18.1"],"introduced":["0"],"last_affected":[],"package":"loggerhead","purl":"pkg:pypi/loggerhead","source":"GHSA-qjmg-77xh-7mjw"},{"ecosystem":"PyPI","fixed":["1.18.1"],"introduced":["0"],"last_affected":[],"package":"loggerhead","purl":"pkg:pypi/loggerhead","source":"PYSEC-2026-840"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2011-0727"},"products":["n/a"],"published":"2011-03-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated users can inject arbitrary scripts via filenames in Loggerhead revision views, potentially compromising other users' sessions.","url":"https://insights.sbomify.com/CVE-2011-0728/"}