{"answers":{"affected":"2 open source packages ship an affected version, including mail. It affects 1 product.","exploited":"There is no known exploitation of CVE-2011-0739 in the wild and no public exploit code.","fix":"Upgrade mail to 2.2.15 or later.","what":"CVE-2011-0739 is a medium-severity command injection vulnerability in n/a, published on 2 Feb 2011. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2011-0739 and fix it if it is affected.\n\nWhat it is: CVE-2011-0739 is a medium-severity command injection vulnerability in n/a, published on 2 Feb 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2011-0739 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mail (RubyGems): affected all versions; fixed in 2.2.15\n- mail (RubyGems): affected all versions; fixed in 2.2.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-0739/ (Markdown: https://insights.sbomify.com/CVE-2011-0739/index.md)","id":"CVE-2011-0739","markdown":"https://insights.sbomify.com/CVE-2011-0739/index.md","name":"CVE-2011-0739","record":{"aliases":["GHSA-cpjc-p7fc-j9xh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby Mail gem","requires_auth":"none","summary":"Remote attackers can execute arbitrary commands via shell metacharacters in email addresses using the Ruby Mail gem's sendmail delivery agent.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mail","vendor":"mikel_lindsaar"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The deliver function in the sendmail delivery agent (lib/mail/network/delivery_methods/sendmail.rb) in Ruby Mail gem 2.2.14 and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in an e-mail address.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mail Improper Input Validation vulnerability","id":"CVE-2011-0739","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2011"},"n_packages":2,"n_references":7,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2011-0740"},"packages":[{"ecosystem":"RubyGems","fixed":["2.2.15"],"introduced":["0"],"last_affected":[],"package":"mail","purl":null,"source":"GHSA-cpjc-p7fc-j9xh"},{"ecosystem":"RubyGems","fixed":["2.2.15"],"introduced":["0"],"last_affected":[],"package":"mail","purl":"pkg:gem/mail","source":"GHSA-cpjc-p7fc-j9xh"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2011-0738"},"products":["n/a"],"published":"2011-02-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary commands via shell metacharacters in email addresses using the Ruby Mail gem's sendmail delivery agent.","url":"https://insights.sbomify.com/CVE-2011-0739/"}