CVE-2011-0986 phpMyAdmin allows remote attackers to obtain installation path via direct request for nonexistent file
Remote attackers can obtain the installation path by requesting missing files, exposing internal directory structures.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2011-0986?
CVE-2011-0986 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 14 Feb 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
phpMyAdmin 2.11.x before 2.11.11.2, and 3.3.x before 3.3.9.1, does not properly handle the absence of the (1) README, (2) ChangeLog, and (3) LICENSE files, which allows remote attackers to obtain the installation path via a direct request for a nonexistent file.
Weakness: CWE-20
Which versions are affected by CVE-2011-0986?
4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 2.11.0 | 2.11.11.2 |
phpmyadmin/phpmyadmin Packagist | From 2.11.0 | 2.11.11.2 |
phpmyadmin/phpmyadmin Packagist | From 3.3.0 | 3.3.9.1 |
phpmyadmin/phpmyadmin Packagist | From 3.3.0 | 3.3.9.1 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2011-0986?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 2.11.11.2 or 3.3.9.1.
Is CVE-2011-0986 being exploited?
There is no known exploitation of CVE-2011-0986 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as DEBIAN-CVE-2011-0986, GHSA-wcmm-28rg-mg3r.