CVE-2011-10003 XpressEngine Update Query sql injection

Medium 5.5 Published Updated

An attacker can perform SQL injection via the Update Query Handler in XpressEngine, potentially reading or modifying database contents.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2011-10003?

CVE-2011-10003 is a medium-severity SQL injection vulnerability in XpressEngine, published on 7 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability was found in XpressEngine up to 1.4.4. It has been rated as critical. This issue affects some unknown processing of the component Update Query Handler. The manipulation leads to sql injection. Upgrading to version 1.4.5 is able to address this issue. The patch is named c6e94449f21256d6362450b29c7847305e756ad5. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220247.

Weakness: CWE-89

Which versions are affected by CVE-2011-10003?

It affects 1 product.

Products include Xpressengine Xpressengine.

How do I fix CVE-2011-10003?

No fix has been published for CVE-2011-10003 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2011-10003 being exploited?

There is no known exploitation of CVE-2011-10003 in the wild and no public exploit code.

Sources

Also known as GHSA-5vgw-2vhf-f6r5.

Is CVE-2011-10003 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free