CVE-2011-10004 reciply Plugin uploadImage.php unrestricted upload

Medium 6.3 Published Updated

Remote attackers can upload malicious files via unrestricted upload in reciply Plugin, potentially leading to code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2011-10004?

CVE-2011-10004 is a medium-severity vulnerability in reciply Plugin, published on 16 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was found in reciply Plugin up to 1.1.7 on WordPress. It has been rated as critical. This issue affects some unknown processing of the file uploadImage.php. The manipulation leads to unrestricted upload. The attack may be initiated remotely. Upgrading to version 1.1.8 is able to address this issue. The identifier of the patch is e3ff616dc08d3aadff9253f1085e13f677d0c676. It is recommended to upgrade the affected component. The identifier VDB-242189 was assigned to this vulnerability.

Weakness: CWE-434

Which versions are affected by CVE-2011-10004?

It affects 1 product.

Products include Reciply Project Reciply.

How do I fix CVE-2011-10004?

No fix has been published for CVE-2011-10004 yet. Limit exposure of the affected software until one is available.

Is CVE-2011-10004 being exploited?

There is no known exploitation of CVE-2011-10004 in the wild and no public exploit code.

Sources

Also known as GHSA-2v35-g5rr-c2v3.

Is CVE-2011-10004 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free