CVE-2011-10006 GamerZ WP-PostRatings wp-postratings.php cross site scripting
Remote attackers can inject malicious scripts via the WP-PostRatings plugin, potentially compromising user sessions or site integrity.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2011-10006?
CVE-2011-10006 is a low-severity cross-site scripting vulnerability in GamerZ WP-PostRatings, published on 8 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A vulnerability was found in GamerZ WP-PostRatings up to 1.64. It has been classified as problematic. This affects an unknown part of the file wp-postratings.php. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 1.65 is able to address this issue. The identifier of the patch is 6182a5682b12369ced0becd3b505439ce2eb8132. It is recommended to upgrade the affected component. The identifier VDB-259629 was assigned to this vulnerability.
Weakness: CWE-79
Which versions are affected by CVE-2011-10006?
It affects 1 product.
Products include Lesterchan Wp-Postratings.
How do I fix CVE-2011-10006?
No fix has been published for CVE-2011-10006 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2011-10006 being exploited?
There is no known exploitation of CVE-2011-10006 in the wild and no public exploit code.
Other vulnerabilities in GamerZ WP-PostRatings
- CVE-2024-39659 WordPress WP-PostRatings plugin <= 1.91.1 - Cross Site Scripting (XSS) vulnerability
- CVE-2011-4646 SQL injection in n/a
- CVE-2023-40332 WordPress WP-PostRatings plugin <= 1.91 - Rating limit Bypass vulnerability
- CVE-2021-25117 WP Postratings < 1.86.1 - Admin+ Stored Cross-Site Scripting
Sources
Also known as GHSA-93gm-4q6q-xv6c.