{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2011-10006 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2011-10006 yet. Limit exposure of the affected software until one is available.","what":"CVE-2011-10006 is a low-severity cross-site scripting vulnerability in GamerZ WP-PostRatings, published on 8 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2011-10006 and fix it if it is affected.\n\nWhat it is: CVE-2011-10006 is a low-severity cross-site scripting vulnerability in GamerZ WP-PostRatings, published on 8 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2011-10006 in the wild and no public exploit code.\n\nAffected product: GamerZ WP-PostRatings. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-10006/ (Markdown: https://insights.sbomify.com/CVE-2011-10006/index.md)","id":"CVE-2011-10006","markdown":"https://insights.sbomify.com/CVE-2011-10006/index.md","name":"CVE-2011-10006","record":{"aliases":["GHSA-93gm-4q6q-xv6c"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Remote attackers can inject malicious scripts via the WP-PostRatings plugin, potentially compromising user sessions or site integrity.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"wp-postratings","vendor":"lesterchan"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in GamerZ WP-PostRatings up to 1.64. It has been classified as problematic. This affects an unknown part of the file wp-postratings.php. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 1.65 is able to address this issue. The identifier of the patch is 6182a5682b12369ced0becd3b505439ce2eb8132. It is recommended to upgrade the affected component. The identifier VDB-259629 was assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"GamerZ WP-PostRatings wp-postratings.php cross site scripting","id":"CVE-2011-10006","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2011"},"n_packages":0,"n_references":5,"next":{"headline":"Command injection in File::Find::Rule","id":"CVE-2011-10007"},"packages":[],"prev":{"headline":"EasyFTP MKD Command buffer overflow","id":"CVE-2011-10005"},"products":["WP-PostRatings"],"published":"2024-04-08","related":[{"cvss_score":6.5,"headline":"WordPress WP-PostRatings plugin \u003c= 1.91.1 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-39659","kev_date_added":null,"published":"2024-08-01"},{"cvss_score":6,"headline":"SQL injection in n/a","id":"CVE-2011-4646","kev_date_added":null,"published":"2011-11-30"},{"cvss_score":5.3,"headline":"WordPress WP-PostRatings plugin \u003c= 1.91 - Rating limit Bypass vulnerability","id":"CVE-2023-40332","kev_date_added":null,"published":"2024-06-04"},{"cvss_score":4.8,"headline":"WP Postratings \u003c 1.86.1 - Admin+ Stored Cross-Site Scripting","id":"CVE-2021-25117","kev_date_added":null,"published":"2024-01-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-07","vendors":["GamerZ"]},"summary":"Remote attackers can inject malicious scripts via the WP-PostRatings plugin, potentially compromising user sessions or site integrity.","url":"https://insights.sbomify.com/CVE-2011-10006/"}