# CVE-2011-10019: Spreecommerce < 0.60.2 Search Parameter RCE

> Attackers can execute arbitrary shell commands on the server via unsanitized input in the search functionality of Spreecommerce.

- **Severity:** Critical 10.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2025
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-97vm-c39p-jr86

## What is CVE-2011-10019?

CVE-2011-10019 is a critical code injection vulnerability in Spreecommerce, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spreecommerce versions prior to 0.60.2 contains a remote command execution vulnerability in its search functionality. The application fails to properly sanitize input passed via the search[send][] parameter, which is dynamically invoked using Ruby’s send method. This allows attackers to execute arbitrary shell commands on the server without authentication.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2011-10019?

2 open source packages ship an affected version, including spree. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `spree` | RubyGems | All versions | 0.60.2 |
| `spree` | RubyGems | All versions | 0.60.2 |

Products: Spreecommerce Spree.

## How do I fix CVE-2011-10019?

Upgrade spree to 0.60.2 or later.

## Is CVE-2011-10019 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-10019 exists.

Public exploit code:

- Spreecommerce 0.60.1 Arbitrary Command Execution (metasploit)

## Other vulnerabilities in Spreecommerce

- [CVE-2011-10026](https://insights.sbomify.com/CVE-2011-10026/): Spreecommerce < 0.50.x API RCE (critical 9.3)
- [CVE-2026-25757](https://insights.sbomify.com/CVE-2026-25757/): Unauthenticated Spree Commerce users can view completed guest orders by Order ID (high 7.7)
- [CVE-2026-25758](https://insights.sbomify.com/CVE-2026-25758/): Spree allows unauthenticated users can access all guest addresses (high 7.7)
- [CVE-2020-26223](https://insights.sbomify.com/CVE-2020-26223/): Authorization bypass in Spree (high 7.7)
- [CVE-2026-22589](https://insights.sbomify.com/CVE-2026-22589/): Spree API has Unauthenticated IDOR - Guest Address (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-10019 and fix it if it is affected.

What it is: CVE-2011-10019 is a critical code injection vulnerability in Spreecommerce, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-10019 exists.

Affected packages and fixed versions:
- spree (RubyGems): affected all versions; fixed in 0.60.2
- spree (RubyGems): affected all versions; fixed in 0.60.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-10019/ (Markdown: https://insights.sbomify.com/CVE-2011-10019/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-10019
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-10019
- OSV: https://osv.dev/vulnerability/CVE-2011-10019

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-10019/
Summaries are generated and may contain mistakes; the official description above is the record.
