# CVE-2011-1058: MoinMoin Cross-site Scripting (XSS) vulnerability

> Remote attackers can inject arbitrary web script or HTML via crafted URLs in MoinMoin wiki when reStructuredText parsing is enabled.

- **Severity:** Low 2.6 (`AV:N/AC:H/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Feb 2011
- **Updated:** 6 Aug 2024
- **Also known as:** DSA-2321-1, GHSA-m9j7-xcj7-42j9, PYSEC-2011-6

## What is CVE-2011-1058?

CVE-2011-1058 is a low-severity cross-site scripting vulnerability in n/a, published on 22 Feb 2011. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the reStructuredText (rst) parser in parser/text_rst.py in MoinMoin before 1.9.3, when docutils is installed or when "format rst" is set, allows remote attackers to inject arbitrary web script or HTML via a javascript: URL in the refuri attribute.  NOTE: some of these details are obtained from third party information.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2011-1058?

3 open source packages ship an affected version, including moin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moin` | PyPI | All versions | 1.9.3 |
| `moin` | PyPI | All versions | 1.9.3 |
| `moin` | PyPI | All versions | 1.9.3 |

Products: Moinmo Moinmoin.

## How do I fix CVE-2011-1058?

Upgrade moin to 1.9.3 or later.

## Is CVE-2011-1058 being exploited?

There is no known exploitation of CVE-2011-1058 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-15275](https://insights.sbomify.com/CVE-2020-15275/): malicious SVG attachment causing stored XSS vulnerability in MoinMoin (high 8.7)
- [CVE-2009-4762](https://insights.sbomify.com/CVE-2009-4762/): MoinMoin Improper Access Control vulnerability (high 7.5)
- [CVE-2010-0669](https://insights.sbomify.com/CVE-2010-0669/): MoinMoin improper sanitizes user profiles (high 7.5)
- [CVE-2010-0717](https://insights.sbomify.com/CVE-2010-0717/): MoinMoin has improper default configuration (high 7.5)
- [CVE-2010-0668](https://insights.sbomify.com/CVE-2010-0668/): MoinMoin has multiple vulnerabilities related to superuser list, xmlrpc and OpenID configuration (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-1058 and fix it if it is affected.

What it is: CVE-2011-1058 is a low-severity cross-site scripting vulnerability in n/a, published on 22 Feb 2011. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2011-1058 in the wild and no public exploit code.

Affected packages and fixed versions:
- moin (PyPI): affected all versions; fixed in 1.9.3
- moin (PyPI): affected all versions; fixed in 1.9.3
- moin (PyPI): affected all versions; fixed in 1.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-1058/ (Markdown: https://insights.sbomify.com/CVE-2011-1058/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-1058
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-1058
- OSV: https://osv.dev/vulnerability/CVE-2011-1058

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-1058/
Summaries are generated and may contain mistakes; the official description above is the record.
