# CVE-2011-1156: feedparser denial of service vulnerability

> Remote attackers can crash the application by sending a malformed DOCTYPE declaration to the Universal Feed Parser library.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2011
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2011-1156, GHSA-6h52-4vmh-8x4f, PYSEC-2011-19

## What is CVE-2011-1156?

CVE-2011-1156 is a medium-severity denial of service vulnerability in n/a, published on 11 Apr 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0.1 allows remote attackers to cause a denial of service (application crash) via a malformed DOCTYPE declaration.

Weakness: CWE-399

## Which versions are affected by CVE-2011-1156?

3 open source packages ship an affected version, including feedparser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `feedparser` | PyPI | All versions | 5.0.1 |
| `feedparser` | PyPI | From 4.1 | 5.0.1 |
| `feedparser` | PyPI | From 4.1 | 5.0.1 |

Products: Mark Pilgrim Feedparser.

## How do I fix CVE-2011-1156?

Upgrade feedparser to 5.0.1 or later.

## Is CVE-2011-1156 being exploited?

There is no known exploitation of CVE-2011-1156 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2012-2921](https://insights.sbomify.com/CVE-2012-2921/): feedparser denial of service vulnerability (medium 5.0)
- [CVE-2009-5065](https://insights.sbomify.com/CVE-2009-5065/): feedparser Cross-site Scripting vulnerability (medium 4.3)
- [CVE-2011-1157](https://insights.sbomify.com/CVE-2011-1157/): feedparser Cross-site Scripting vulnerability (medium 4.3)
- [CVE-2011-1158](https://insights.sbomify.com/CVE-2011-1158/): feedparser Cross-site Scripting vulnerability (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-1156 and fix it if it is affected.

What it is: CVE-2011-1156 is a medium-severity denial of service vulnerability in n/a, published on 11 Apr 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-1156 in the wild and no public exploit code.

Affected packages and fixed versions:
- feedparser (PyPI): affected all versions; fixed in 5.0.1
- feedparser (PyPI): affected from 4.1; fixed in 5.0.1
- feedparser (PyPI): affected from 4.1; fixed in 5.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-1156/ (Markdown: https://insights.sbomify.com/CVE-2011-1156/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-1156
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-1156
- OSV: https://osv.dev/vulnerability/CVE-2011-1156

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-1156/
Summaries are generated and may contain mistakes; the official description above is the record.
