CVE-2011-1497 Cross site scripting in actionpack Rubygem

Medium 6.1 Published Updated

An XSS flaw in the auto_link function allows attackers to inject malicious scripts, requiring an upgrade to Rails.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2011-1497?

CVE-2011-1497 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 19 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A cross-site scripting vulnerability flaw was found in the auto_link function in Rails before version 3.0.6.

Weakness: CWE-79

Which versions are affected by CVE-2011-1497?

2 open source packages ship an affected version, including actionpack. It affects 1 product.

PackageAffectedFixed in
actionpack RubyGemsFrom 3.0.0.rc3.0.6
actionpack RubyGemsFrom 3.0.0.rc3.0.6

Products include Rubyonrails Rails.

How do I fix CVE-2011-1497?

Upgrade actionpack to 3.0.6 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2011-1497 being exploited?

There is no known exploitation of CVE-2011-1497 in the wild and no public exploit code.

All Rubyonrails Rails vulnerabilities

Sources

Also known as GHSA-q58j-fmvf-9rq6.

Is CVE-2011-1497 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free