{"answers":{"affected":"2 open source packages ship an affected version, including actionpack. It affects 1 product.","exploited":"There is no known exploitation of CVE-2011-1497 in the wild and no public exploit code.","fix":"Upgrade actionpack to 3.0.6 or later.","what":"CVE-2011-1497 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 19 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2011-1497 and fix it if it is affected.\n\nWhat it is: CVE-2011-1497 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 19 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2011-1497 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- actionpack (RubyGems): affected from 3.0.0.rc; fixed in 3.0.6\n- actionpack (RubyGems): affected from 3.0.0.rc; fixed in 3.0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-1497/ (Markdown: https://insights.sbomify.com/CVE-2011-1497/index.md)","id":"CVE-2011-1497","markdown":"https://insights.sbomify.com/CVE-2011-1497/index.md","name":"CVE-2011-1497","record":{"aliases":["GHSA-q58j-fmvf-9rq6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails","requires_auth":"none","summary":"An XSS flaw in the auto_link function allows attackers to inject malicious scripts, requiring an upgrade to Rails.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"rails","vendor":"rubyonrails"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A cross-site scripting vulnerability flaw was found in the auto_link function in Rails before version 3.0.6.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross site scripting in actionpack Rubygem","id":"CVE-2011-1497","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"rubyonrails:rails","products":["rubyonrails:rails"],"type":"xss","year":"2011"},"n_packages":2,"n_references":2,"next":{"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Apache HttpClient","id":"CVE-2011-1498"},"packages":[{"ecosystem":"RubyGems","fixed":["3.0.6"],"introduced":["3.0.0.rc"],"last_affected":[],"package":"actionpack","purl":null,"source":"GHSA-q58j-fmvf-9rq6"},{"ecosystem":"RubyGems","fixed":["3.0.6"],"introduced":["3.0.0.rc"],"last_affected":[],"package":"actionpack","purl":"pkg:gem/actionpack","source":"GHSA-q58j-fmvf-9rq6"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2011-1496"},"products":["rails"],"published":"2021-10-19","related":[{"cvss_score":10,"headline":"Active Record contains deserialization of arbitrary YAML","id":"CVE-2013-0277","kev_date_added":null,"published":"2013-02-13"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2017-17916","kev_date_added":null,"published":"2017-12-29"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2017-17917","kev_date_added":null,"published":"2017-12-29"},{"cvss_score":8,"headline":"Rails Active Storage has possible Path Traversal in DiskService","id":"CVE-2026-33195","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":7.5,"headline":"Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch","id":"CVE-2024-26142","kev_date_added":null,"published":"2024-02-27"},{"cvss_score":7.5,"headline":"ReDoS based DoS vulnerability in Action Dispatch","id":"CVE-2023-22792","kev_date_added":null,"published":"2023-02-09"},{"cvss_score":7.5,"headline":"Denial of Service in Action Dispatch","id":"CVE-2021-22902","kev_date_added":null,"published":"2021-06-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"An XSS flaw in the auto_link function allows attackers to inject malicious scripts, requiring an upgrade to Rails.","url":"https://insights.sbomify.com/CVE-2011-1497/"}